remove autoconf from prereq-build.mk, as it is part of the tools/ build
[openwrt.git] / include / prereq-build.mk
index b0114f0..0b396c8 100644 (file)
@@ -37,6 +37,20 @@ $(eval $(call Require,case-sensitive-fs, \
        OpenWrt can only be built on a case-sensitive filesystem \
 ))
 
+define Require/getopt
+       getopt --help 2>&1 | grep long >/dev/null
+endef
+$(eval $(call Require,getopt, \
+       Please install GNU getopt \
+))
+
+define Require/fileutils
+       gcp --help || cp --help
+endef
+$(eval $(call Require,fileutils, \
+       Please install GNU fileutils \
+))
+
 define Require/working-gcc
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -
@@ -79,10 +93,6 @@ $(eval $(call RequireCommand,gawk, \
        Please install GNU awk. \
 ))
 
-$(eval $(call RequireCommand,bison, \
-       Please install GNU bison. \
-))
-
 $(eval $(call RequireCommand,flex, \
        Please install flex. \
 ))
@@ -103,6 +113,10 @@ $(eval $(call RequireCommand,perl, \
        Please install perl. \
 ))
 
+$(eval $(call RequireCommand,python, \
+       Please install python. \
+))
+
 $(eval $(call RequireCommand,wget, \
        Please install wget. \
 ))
@@ -119,10 +133,6 @@ $(eval $(call RequireCommand,svn, \
        Please install the subversion client. \
 ))
 
-$(eval $(call RequireCommand,autoconf, \
-       Please install GNU autoconf. \
-))
-
 define Require/gnu-find
        $(FIND) $(TMP_DIR) -lname foo
 endef
@@ -130,3 +140,11 @@ endef
 $(eval $(call Require,gnu-find, \
        Please install GNU find \
 ))
+
+define Require/getopt-extended
+       getopt --long - - >/dev/null
+endef
+
+$(eval $(call Require,getopt-extended, \
+       Please install an extended getopt version that supports --long \
+))