[ramips] share memory size detection code
[openwrt.git] / include / kernel.mk
index 5d5c9e9..cb62e63 100644 (file)
@@ -53,12 +53,7 @@ ifneq (,$(findstring uml,$(BOARD)))
   LINUX_KARCH=um
 else
   ifeq (,$(LINUX_KARCH))
-    LINUX_KARCH=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/x86/' \
-         -e 's/mipsel/mips/' \
-         -e 's/mipseb/mips/' \
-         -e 's/sh[234]/sh/' \
-         -e 's/armeb/arm/' \
-    )
+    LINUX_KARCH=$(strip $(subst i386,x86,$(subst armeb,arm,$(subst mipsel,mips,$(subst mips64,mips,$(subst mips64el,mips,$(subst sh2,sh,$(subst sh3,sh,$(subst sh4,sh,$(ARCH))))))))))
   endif
 endif
 
@@ -82,6 +77,7 @@ define ModuleAutoLoad
        $(3) \
        if [ -n "$$$$$$$$modules" ]; then \
                mkdir -p $(2)/etc/modules.d; \
+               mkdir -p $(2)/CONTROL; \
                echo "#!/bin/sh" > $(2)/CONTROL/postinst; \
                echo "[ -z \"\$$$$$$$$IPKG_INSTROOT\" ] || exit 0" >> $(2)/CONTROL/postinst; \
                echo ". /etc/functions.sh" >> $(2)/CONTROL/postinst; \