fixed wpa2 support for madwifi/wpa_supplicant
[openwrt.git] / include / kernel.mk
index b82668e..7486057 100644 (file)
@@ -43,7 +43,9 @@ else
   TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
   LINUX_SITE:=@KERNEL/linux/kernel/v$(KERNEL)$(TESTING) \
 
-  PKG_BUILD_DIR ?= $(KERNEL_BUILD_DIR)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
+  ifneq ($(TARGET_BUILD),1)
+    PKG_BUILD_DIR ?= $(KERNEL_BUILD_DIR)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
+  endif
 endif
 
 ifneq (,$(findstring uml,$(BOARD)))
@@ -113,8 +115,7 @@ $(call KernelPackage/$(1)/description)
     endef
   endif
 
-  # check that all CONFIG_* symbols in $(KCONFIG) are set to 'm'
-  ifeq ($(filter-out m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$(if $($(c)),$($(c)),n))),)
+  ifneq ($(if $(KCONFIG),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
     ifneq ($(strip $(FILES)),)
       define Package/kmod-$(1)/install
                  mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)
@@ -123,6 +124,12 @@ $(call KernelPackage/$(1)/description)
                  $(call KernelPackage/$(1)/install,$$(1))
       endef
     endif
+  $(if $(CONFIG_PACKAGE_kmod-$(1)),
+    else
+      compile: kmod-$(1)-unavailable
+      kmod-$(1)-unavailable:
+               @echo "WARNING: kmod-$(1) is not available in the kernel config"
+  )
   endif
   $$(eval $$(call BuildPackage,kmod-$(1)))