NIU:
[project/luci.git] / contrib / uci / Makefile
index 19625aa..b392787 100644 (file)
@@ -20,12 +20,13 @@ include ../../build/module.mk
 $(UCI_FILE):
        wget -O $@ "$(UCI_URL)" || rm -f $@
 
-$(UCI_PATCHDIR)/series:
-       (cd $(UCI_PATCHDIR); ls *.patch | sort > series)
-
 $(UCI_DIR)/.prepared: $(UCI_FILE)
        rm -rf $(UCI_DIR)
        tar xvfz $(UCI_FILE)
+       (cd $(UCI_PATCHDIR); ls *.patch | sort > series) || true
+       [ -f "$(UCI_PATCHDIR)/series" ] && while read patch; do \
+               patch -d $(UCI_DIR) -p1 < $(UCI_PATCHDIR)/$$patch; \
+       done < $(UCI_PATCHDIR)/series || true
        touch $@
 
 compile: $(UCI_DIR)/.prepared