Add PKG_LICENSE variable to the most of the packages.
[feed/telephony.git] / admin / asterisk11-gui / Makefile
index 67d6d68..c21e43b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,13 +9,16 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=asterisk11-gui
 PKG_VERSION:=2.1.0-rc1
-PKG_RELEASE:=2
+PKG_RELEASE:=4
 
 PKG_SOURCE_URL:=http://downloads.asterisk.org/pub/telephony/asterisk-gui/releases/
 PKG_SOURCE:=asterisk-gui-$(PKG_VERSION).tar.gz
 PKG_MD5SUM:=055bf2aaba365e696198925d039ac3cb
 PKG_BUILD_DIR:=$(BUILD_DIR)/asterisk11-gui-$(PKG_VERSION)
 
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING LICENSE
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/asterisk11-gui
@@ -68,15 +71,6 @@ define Package/asterisk11-gui/install
        $(INSTALL_DIR) $(1)/usr/lib/asterisk/scripts
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/asterisk/scripts/* $(1)/usr/lib/asterisk/scripts
        $(INSTALL_DIR) $(1)/usr/lib/asterisk/gui_backups
-       $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(CP)   ./files/agui-postinst $(1)/etc/uci-defaults/
-endef
-
-define Package/asterisk11-gui/postinst
-       #!/bin/sh
-       [ -n "$${IPKG_INSTROOT}" ] && exit
-       . /lib/functions.sh
-       uci_apply_defaults
 endef
 
 $(eval $(call BuildPackage,asterisk11-gui))