[kernel] refresh 2.6.26 patches
[openwrt.git] / target / linux / ixp4xx / patches-2.6.26 / 295-latch_led_driver.patch
index d1f320f..93fc7cd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -117,6 +117,12 @@
+@@ -117,6 +117,12 @@ config LEDS_GPIO
          outputs. To be useful the particular board must have LEDs
          and they must be connected to the GPIO lines.
  
          outputs. To be useful the particular board must have LEDs
          and they must be connected to the GPIO lines.
  
 +MODULE_LICENSE("GPL");
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
 +MODULE_LICENSE("GPL");
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -18,6 +18,7 @@
+@@ -18,6 +18,7 @@ obj-$(CONFIG_LEDS_H1940)             += leds-h1940.
  obj-$(CONFIG_LEDS_COBALT_QUBE)                += leds-cobalt-qube.o
  obj-$(CONFIG_LEDS_COBALT_RAQ)         += leds-cobalt-raq.o
  obj-$(CONFIG_LEDS_GPIO)                       += leds-gpio.o
  obj-$(CONFIG_LEDS_COBALT_QUBE)                += leds-cobalt-qube.o
  obj-$(CONFIG_LEDS_COBALT_RAQ)         += leds-cobalt-raq.o
  obj-$(CONFIG_LEDS_GPIO)                       += leds-gpio.o
  obj-$(CONFIG_LEDS_HP6XX)              += leds-hp6xx.o
 --- a/include/linux/leds.h
 +++ b/include/linux/leds.h
  obj-$(CONFIG_LEDS_HP6XX)              += leds-hp6xx.o
 --- a/include/linux/leds.h
 +++ b/include/linux/leds.h
-@@ -134,5 +134,18 @@
+@@ -134,5 +134,18 @@ struct gpio_led_platform_data {
                                        unsigned long *delay_off);
  };
  
                                        unsigned long *delay_off);
  };