cleanup Makefile
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 3 Oct 2006 17:30:43 +0000 (17:30 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 3 Oct 2006 17:30:43 +0000 (17:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4898 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/wiviz/Makefile

index e767d0f..654a6ce 100644 (file)
@@ -21,7 +21,6 @@ define Package/wiviz
   CATEGORY:=Network
   DEPENDS:=+libpcap
   TITLE:=Wireless Network Visualization
-  DESCRIPTION:=Wireless Network Visualization
   URL:=http://students.washington.edu/natetrue/wiviz/
 endef
        
@@ -31,16 +30,16 @@ define Build/Prepare
 endef
 
 define Build/Compile
-$(call Build/Compile/Default,CC="$(TARGET_CC)" \
-               CCOPTS="$(TARGET_CFLAGS)" \
-               INCLUDE="-I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib")
+       $(call Build/Compile/Default, \
+               CCOPTS="\$$$$(EXTRA_CFLAGS)" \
+               INCLUDE="" \
+               LDFLAGS="\$$$$(EXTRA_LDFLAGS)" \
+       )
 endef
 
 define Package/wiviz/install   
        mkdir -p $(1)/usr/sbin
        $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
-       $(RSTRIP) $(1)
        $(CP) ./files/* $(1)
        find $(1) -name CVS | xargs rm -rf
        find $(1) -name .svn | xargs rm -rf