[packages] mutella: the previous sed fix to remove host paths failed for autoreconf...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 18 Dec 2010 13:30:30 +0000 (13:30 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 18 Dec 2010 13:30:30 +0000 (13:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@24665 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/mutella/Makefile
net/mutella/patches/004-no-host-paths.patch [new file with mode: 0644]

index afe95b6..ded1b8b 100644 (file)
@@ -43,12 +43,6 @@ endef
 CONFIGURE_VARS += \
        CXXFLAGS="$$$$CXXFLAGS -fno-rtti"  \
 
-define Build/Prepare
-       $(call Build/Prepare/Default)
-       $(SED) 's,-I$$$$(includedir),,g' $(PKG_BUILD_DIR)/{mutella,util}/Makefile.in
-       $(SED) 's,-L$$$$(libdir),,g' $(PKG_BUILD_DIR)/{mutella,util}/Makefile.in
-endef
-
 define Package/mutella/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mutella{,_sio} $(1)/usr/bin/
diff --git a/net/mutella/patches/004-no-host-paths.patch b/net/mutella/patches/004-no-host-paths.patch
new file mode 100644 (file)
index 0000000..c32e524
--- /dev/null
@@ -0,0 +1,58 @@
+--- a/mutella/Makefile.am
++++ b/mutella/Makefile.am
+@@ -12,8 +12,8 @@ EXTRA_DIST = main.cpp common.cpp common.
+ ####### kdevelop will overwrite this part!!! (end)############
+ # set the include path found by configure
+-INCLUDES= $(all_includes) -I$(includedir)
++INCLUDES= $(all_includes)
+  
+ # the library search path.
+-mutella_LDFLAGS = $(all_libraries) -L$(libdir)
++mutella_LDFLAGS = $(all_libraries)
+                                                                                 
+--- a/mutella/Makefile.in
++++ b/mutella/Makefile.in
+@@ -221,10 +221,10 @@ EXTRA_DIST = main.cpp common.cpp common.
+ ####### kdevelop will overwrite this part!!! (end)############
+ # set the include path found by configure
+-INCLUDES = $(all_includes) -I$(includedir)
++INCLUDES = $(all_includes)
+ # the library search path.
+-mutella_LDFLAGS = $(all_libraries) -L$(libdir)
++mutella_LDFLAGS = $(all_libraries)
+ all: all-recursive
+ .SUFFIXES:
+--- a/util/Makefile.am
++++ b/util/Makefile.am
+@@ -9,10 +9,10 @@ bin_PROGRAMS = mutella_sio
+ mutella_sio_SOURCES = sockio.c
+ # set the include path found by configure
+-INCLUDES= $(all_includes) -I$(includedir)
++INCLUDES= $(all_includes)
+ # the library search path.
+-mutella_sio_LDFLAGS = $(all_libraries) -L$(libdir)
++mutella_sio_LDFLAGS = $(all_libraries)
+--- a/util/Makefile.in
++++ b/util/Makefile.in
+@@ -166,10 +166,10 @@ EXTRA_DIST = sockio.c 
+ mutella_sio_SOURCES = sockio.c
+ # set the include path found by configure
+-INCLUDES = $(all_includes) -I$(includedir)
++INCLUDES = $(all_includes)
+ # the library search path.
+-mutella_sio_LDFLAGS = $(all_libraries) -L$(libdir)
++mutella_sio_LDFLAGS = $(all_libraries)
+ all: all-am
+ .SUFFIXES: