[packages] libiconv: declare api functions as extern "C", solves linking with C+...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 4 Jan 2011 14:20:17 +0000 (14:20 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 4 Jan 2011 14:20:17 +0000 (14:20 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@24899 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libiconv/Makefile
libs/libiconv/src/include/iconv.h

index 5006226..b230e6d 100644 (file)
@@ -11,7 +11,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiconv
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 include $(INCLUDE_DIR)/package.mk
 
index bfa08f3..8296f46 100644 (file)
@@ -1,9 +1,14 @@
 #ifndef _ICONV_H
 #define _ICONV_H 1
 
+#define _LIBICONV_VERSION 0x010B    /* version number: (major<<8) + minor */
+
 #include <stddef.h>
 
-#define _LIBICONV_VERSION 0x010B    /* version number: (major<<8) + minor */
+#ifdef __cplusplus
+extern "C" {
+#endif
+
 extern int _libiconv_version; /* Likewise */
 
 typedef long iconv_t;
@@ -18,4 +23,8 @@ iconv(iconv_t cd, char **inbuf, size_t *inbytesleft,
 extern int
 iconv_close(iconv_t cd);
 
+#ifdef __cplusplus
+}
+#endif
+
 #endif /* _ICONV_H */