[packages] debootstrap: update to version 1.0.40
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 28 Apr 2012 19:19:37 +0000 (19:19 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 28 Apr 2012 19:19:37 +0000 (19:19 +0000)
Signed-off-by: Daniel Golle <dgolle@allnet.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@31498 3c298f89-4303-0410-b956-a3cf2f4a3e73

admin/debootstrap/Makefile
admin/debootstrap/files/pkgdetails.c
admin/debootstrap/patches/100-busybox_fix.patch

index 82c81e9..6e6d39d 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=debootstrap
-PKG_VERSION:=1.0.38
+PKG_VERSION:=1.0.40
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-udeb_$(PKG_VERSION)_all.udeb
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/d/debootstrap
-PKG_MD5SUM:=9bc9c55504c73bad27105aeed1a94f42
+PKG_MD5SUM:=298ed4d39eda12b9db46f446465d6f7f
 
 UNPACK_CMD=ar -p "$(DL_DIR)/$(PKG_SOURCE)" data.tar.gz | ( cd $(1) && tar -xzf - )
 
@@ -37,7 +37,7 @@ define Package/debootstrap/description
 endef
 
 define Build/Compile
-# file pkgdetails.c was imported from debian package base-installer version 1.122
+# file pkgdetails.c was imported from debian package base-installer version 1.123
        $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) ./files/pkgdetails.c -o $(PKG_BUILD_DIR)/usr/share/debootstrap/pkgdetails
 endef
 
index 359807b..99ee190 100644 (file)
@@ -12,7 +12,7 @@ char *checksum_field=NULL;
 
 static void oom_die(void)
 {
-    fprintf(stderr, "Out of memory!\n");
+    fputs("Out of memory!\n", stderr);
     exit(1);
 }
 
index 124d7a4..0b248c7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/usr/share/debootstrap/functions
 +++ b/usr/share/debootstrap/functions
-@@ -839,8 +839,6 @@ choose_extractor () {
+@@ -832,8 +832,6 @@ choose_extractor () {
  
        if [ -n "$EXTRACTOR_OVERRIDE" ]; then
                extractor="$EXTRACTOR_OVERRIDE"