[libftdi]
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 9 May 2011 20:20:22 +0000 (20:20 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 9 May 2011 20:20:22 +0000 (20:20 +0000)
Adds libfti - a C-library to interface FTDI USB-serial-chips.
Package may need improvement, source libftdi also provides a C++ binding
which is not getting installed with this package yet.

Signed-off-by: Michael Markstaller <mm@elabnet.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26867 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libftdi/Makefile [new file with mode: 0644]

diff --git a/libs/libftdi/Makefile b/libs/libftdi/Makefile
new file mode 100644 (file)
index 0000000..17a8e60
--- /dev/null
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libftdi
+PKG_VERSION:=0.18
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.intra2net.com/en/developer/libftdi/download/
+PKG_MD5SUM:=916f65fa68d154621fc0cf1f405f2726
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libftdi
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=library to talk to FTDI chips
+  URL:=http://www.intra2net.com/en/developer/libftdi/
+endef
+
+define Package/libftdi/description
+  libFTDI - FTDI USB driver with bitbang mode
+  libFTDI is an open source library to talk to FTDI chips: FT232BM, FT245BM, FT2232C, FT2232H, FT4232H, FT2232D and FT245R, including the popular bitbang mode. 
+  The library is linked with your program in userspace, no kernel driver required.
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/ftdi.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libftdi.{a,so} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libftdi.so* $(1)/usr/lib/
+endef
+
+define Package/libftdi/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libftdi.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libftdi))