[packages] multiwan: Fixed last WAN probability to be 1.0.
authorcraigc <craigc@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 10 May 2010 16:54:53 +0000 (16:54 +0000)
committercraigc <craigc@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 10 May 2010 16:54:53 +0000 (16:54 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@21416 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/multiwan/Makefile
net/multiwan/files/usr/bin/multiwan

index d7c98df..563b8cc 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=multiwan
 PKG_VERSION:=1.0.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 include $(INCLUDE_DIR)/package.mk
 
index 7e5a735..f94166a 100755 (executable)
@@ -692,7 +692,7 @@ last_probability=$rand_probability
 
         if [ $rand_probability -lt 10 ]; then
                 rand_probability="0.0${rand_probability}"
-        elif [ $rand_probability -lt 100 ]; then
+        elif [ $rand_probability -lt 100 -a $i != $wancount ]; then
                 rand_probability="0.${rand_probability}"
         else
                 rand_probability="1.0"