mosquitto: bump 1.2 to 1.2.3
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Feb 2014 22:41:37 +0000 (22:41 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Feb 2014 22:41:37 +0000 (22:41 +0000)
This includes UCI support for a new config option, bridge_tls_version.
Add bridge tls vesion support

Updates mosquitto, the MQTT broker, and client libraries to version
1.2.2, from version 1.2.0.  Changes are bugfixes, most relevant to
OpenWrt being that the -nossl package variant actually builds again,
and greatly improved SSL performance.

This includes the full changes for 1.2.3:
http://mosquitto.org/2013/12/version-1-2-3-released/

This includes the full changes for 1.2.2:
http://mosquitto.org/2013/10/version-1-2-2-released/

This includes the full changes for 1.2.1:
http://mosquitto.org/2013/09/version-1-2-1-released/

Signed-off-by: Karl Palsson <karlp@remake.is>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39495 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/mosquitto/Makefile
net/mosquitto/files/mosquitto.uci.convert

index f4ba8ed..45250c8 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mosquitto
-PKG_VERSION:=1.2
+PKG_VERSION:=1.2.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://mosquitto.org/files/source/
-PKG_MD5SUM:=424bfd84a7c923ccc2ea36c8bee558b2
+PKG_MD5SUM:=0874beeff51b3c64d4a7b2d5f9498288
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
index f8991a3..7932ef1 100644 (file)
@@ -80,5 +80,9 @@ if [ $HATE_SECTION_COUNT -gt 0 ]; then
         if [ $? -eq 0 ]; then
             echo "bridge_psk $BRIDGEPSK" >> $TCONF
         fi
+        BRIDGETLSVERSION=$(uci -q get mosquitto.@bridge[-$i].tls_version)
+        if [ $? -eq 0 ]; then
+            echo "bridge_tls_version $BRIDGETLSVERSION" >> $TCONF
+        fi
     done
 fi