aalib: fixed build configuration
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Feb 2014 20:15:32 +0000 (20:15 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Feb 2014 20:15:32 +0000 (20:15 +0000)
Signed-off-by: Michel Stempin <michel.stempin@wanadoo.fr>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39653 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/aalib/Makefile
libs/aalib/patches/002-configure.patch [new file with mode: 0644]

index 274584b..a980bf1 100644 (file)
@@ -36,8 +36,8 @@ define Build/Configure
                --enable-shared \
                --enable-static \
                --without-x \
-               --without-x11-driver \
-               --without-slang-driver \
+               --with-x11-driver=no \
+               --with-slang-driver=no \
                --with-ncurses=$(STAGING_DIR)/usr \
        )
 endef
diff --git a/libs/aalib/patches/002-configure.patch b/libs/aalib/patches/002-configure.patch
new file mode 100644 (file)
index 0000000..945d3de
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/configure.in
++++ b/configure.in
+@@ -88,7 +88,7 @@
+ AC_ARG_WITH(slang-driver,
+         [  --with-slang-driver=no   Used to disable slang driver],[
+       if test x$withval = xno; then
+-        vga_driver_test=no
++        slang_driver_test=no
+       fi
+ ])
+ AC_ARG_WITH(curses-driver,