cleanup, fix usage of cflags
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 Jul 2007 10:01:16 +0000 (10:01 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 Jul 2007 10:01:16 +0000 (10:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8259 3c298f89-4303-0410-b956-a3cf2f4a3e73

admin/osiris/Makefile

index d3037e9..73da8e6 100644 (file)
@@ -30,22 +30,16 @@ define Package/osirisd
   URL:=http://www.hostintegrity.com/osiris
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --with-osiris-user=root \
-               --with-root-dir=/var/lib/osiris \
-               --with-readline=no, \
-               ac_cv_openssldir="$(STAGING_DIR)/usr" \
-       )
-endef
+CONFIGURE_ARGS += \
+       --with-osiris-user=root \
+       --with-root-dir=/var/lib/osiris \
+       --with-readline=no, \
+       ac_cv_openssldir="$(STAGING_DIR)/usr"
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
+MAKE_FLAGS += \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INTERACTIVE=0 \
                all install
-endef
 
 define Package/osirisd/install 
        $(INSTALL_DIR) $(1)/usr/sbin