postgresql: update to 9.0.15
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 6 Feb 2014 21:11:43 +0000 (21:11 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 6 Feb 2014 21:11:43 +0000 (21:11 +0000)
Without TARGET_CFLAGS += -lpthread it does not find libpthread and the build fails.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39514 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/postgresql/Makefile

index 37ae8f6..f9086bb 100644 (file)
@@ -8,16 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
-PKG_VERSION:=9.0.1
-PKG_RELEASE:=4
+PKG_VERSION:=9.0.15
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=\
        http://ftp9.us.postgresql.org/pub/mirrors/postgresql/source/v$(PKG_VERSION) \
        http://ftp.be.postgresql.org/postgresql/source/v$(PKG_VERSION) \
        ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
-PKG_MD5SUM:=57ba57e43cfe29e16dacbf5789be98d1
+PKG_MD5SUM:=1bd7f659c4f68e5fc23511c6952b494b
 PKG_BUILD_PARALLEL:=1
+PKG_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -154,7 +155,7 @@ define Build/Configure
        $(SED) 's@ECPG = ../../preproc/ecpg@ECPG = ../../preproc/ecpg.host@' $(PKG_BUILD_DIR)/src/interfaces/ecpg/test/Makefile.regress
 endef
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) -lpthread
 
 # because PROFILE means something else in the project Makefile
 unexport PROFILE