fix opt flags in cross-compile patch, remove volatile dirs (in /var) from the package...
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 28 Oct 2006 13:30:56 +0000 (13:30 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 28 Oct 2006 13:30:56 +0000 (13:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@5319 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/iptraf/Makefile
net/iptraf/patches/01-cross_compile.patch

index 02c31ee..7812437 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,15 +11,14 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=iptraf
 PKG_VERSION:=3.0.0
 PKG_RELEASE:=1
-PKG_MD5SUM:=377371c28ee3c21a76f7024920649ea8
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://iptraf.seul.org/pub/iptraf/ \
        ftp://the.wiretapped.net/pub/security/network-monitoring/iptraf/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=377371c28ee3c21a76f7024920649ea8
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,14 +27,14 @@ define Package/iptraf
   CATEGORY:=Network
   DEPENDS:=+libncurses
   TITLE:=A console-based network monitoring program
-  DESCRIPTION:=IPTraf is a console-based network statistics utility for Linux. It gathers\\\
-a variety of figures such as TCP connection packet and byte counts,\\\
-interface statistics and activity indicators, TCP/UDP traffic breakdowns,\\\
-and LAN station packet and byte counts.\\\
+  DESCRIPTION:=\
+       IPTraf is a console-based network statistics utility for Linux. It gathers \\\
+       a variety of figures such as TCP connection packet and byte counts, \\\
+       interface statistics and activity indicators, TCP/UDP traffic breakdowns, \\\
+       and LAN station packet and byte counts.
   URL:=http://iptraf.seul.org/
 endef
 
-
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR)/src \
                $(TARGET_CONFIGURE_OPTS) \
@@ -49,9 +49,7 @@ define Build/Compile
 endef
 
 define Package/iptraf/install  
-       install -d -m0755 $(1)/usr/bin \
-                         $(1)/var/run/iptraf \
-                         $(1)/var/lib/iptraf
+       install -d -m0755 $(1)/usr/bin
        install -m0755 $(PKG_BUILD_DIR)/src/iptraf $(1)/usr/bin/
 endef
 
index c12719d..574367b 100644 (file)
@@ -18,7 +18,7 @@ diff -urN iptraf-3.0.0/support/Makefile iptraf-3.0.0.new/support/Makefile
  
  %.o: %.c *.h
 -      gcc -O2 -g -Wall -fPIC $(INCLUDEDIR) -c -o $*.o $<
-+      $(CC) -O2 -g -Wall -fPIC $(INCLUDEDIR) -c -o $*.o $<
++      $(CC) $(CFLAGS) -Wall -fPIC $(INCLUDEDIR) -c -o $*.o $<
  
  clean:
        rm -rf *.o *~ libtextbox.a libtextbox.so