[packages] c++ fixes:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 3 May 2008 02:30:04 +0000 (02:30 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 3 May 2008 02:30:04 +0000 (02:30 +0000)
 - don't link with both uClibc++ and stdlibc++ (closes: #1248 and other segfaults at startup)
 - change dependency from uclibcxx to libstdcpp
 - bump release number
 - cleanup

git-svn-id: svn://svn.openwrt.org/openwrt/packages@11013 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libsigc++/Makefile
libs/libtorrent/Makefile
libs/wxbase/Makefile
net/amule/Makefile
net/mutella/Makefile
net/rtorrent/Makefile

index a3104b8..f9ac80c 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006,2007 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,25 +10,22 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libsigc++
 PKG_VERSION:=2.0.17
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.0/
 PKG_MD5SUM:=fde0ee69e3125e982746d9fe005763e1
 
-PKG_BUILD_DEPENDS:=libtool
-
 PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libsigcxx
-  NAME:=libsigc++
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=typesafe callback system for standard C++
   URL:=http://libsigc++.sourceforge.net/
-  DEPENDS:=+uclibcxx
+  DEPENDS:=+libstdcpp
 endef
 
 define Package/libsigcxx/description
@@ -42,30 +39,22 @@ CONFIGURE_ARGS += \
        --enable-static \
 
 CONFIGURE_VARS += \
-       CXX="g++-uc+std" \
        CXXFLAGS="$$$$CXXFLAGS -fno-rtti"  \
 
-define Build/Configure
-       $(call Build/Configure/Default,)
-       $(SED) 's|^sys_lib_dlsearch_path_spec=.*|sys_lib_dlsearch_path_spec="$(STAGING_DIR)/usr/lib"|g' \
-               $(PKG_BUILD_DIR)/libtool
-       $(SED) 's|^postdeps=.*|postdeps=|g' $(PKG_BUILD_DIR)/libtool
-endef
-
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) all
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/sigc++-2.0 $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsigc-2.0.{a,so*} $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/sigc++-2.0 $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sigc++-2.0.pc $(1)/usr/lib/pkgconfig/
-       $(SED) 's,$(TARGET_LDFLAGS),,g' $(1)/usr/lib/pkgconfig/sigc++-2.0.pc
 endef
 
 define Package/libsigcxx/install
index df490b3..5de0323 100644 (file)
@@ -10,14 +10,12 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libtorrent
 PKG_VERSION:=0.11.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://libtorrent.rakshasa.no/downloads/
 PKG_MD5SUM:=8974dc9499b382a09fb952cabcfef9a0
 
-PKG_BUILD_DEPENDS:=libtool
-
 PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
@@ -27,7 +25,7 @@ define Package/libtorrent
   CATEGORY:=Libraries
   TITLE:=Rakshasa's BitTorrent library
   URL:=http://libtorrent.rakshasa.no/
-  DEPENDS:=+libsigcxx
+  DEPENDS:=+libopenssl +libsigcxx
 endef
 
 define Package/libtorrent/description
@@ -38,38 +36,30 @@ define Package/libtorrent/description
  the speed of the official client.
 endef
 
+# XXX: rtorrent needs encryption (--enable-openssl)
 CONFIGURE_ARGS+= \
        --enable-shared \
        --enable-static \
        --enable-aligned \
        --disable-debug \
-       --disable-openssl \
+       --enable-openssl \
 
 CONFIGURE_VARS += \
-       CXX="g++-uc+std" \
        CXXFLAGS="$$$$CXXFLAGS -fno-rtti"  \
 
-define Build/Configure
-       $(call Build/Configure/Default,)
-       $(SED) 's|^sys_lib_dlsearch_path_spec=.*|sys_lib_dlsearch_path_spec="$(STAGING_DIR)/usr/lib"|g' \
-               $(PKG_BUILD_DIR)/libtool
-       $(SED) 's|^postdeps=.*|postdeps=|g' $(PKG_BUILD_DIR)/libtool
-endef
-
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) all
-       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/torrent $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtorrent.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libtorrent.pc $(1)/usr/lib/pkgconfig/
-       $(SED) 's,$(TARGET_LDFLAGS),,g' $(1)/usr/lib/pkgconfig/libtorrent.pc
 endef
 
 define Package/libtorrent/install
index 930a815..8c82acf 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wxbase
 PKG_VERSION:=2.8.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=wxGTK-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/wxwindows
@@ -25,7 +25,7 @@ define Package/libwxbase
   CATEGORY:=Libraries
   TITLE:=Cross-platform C++ framework
   URL:=http://www.wxwidgets.org/
-  DEPENDS:=+libexpat +uclibcxx +zlib
+  DEPENDS:=+libexpat +libstdcpp +zlib
 endef
 
 define Package/libwxbase/description
@@ -103,9 +103,6 @@ CONFIGURE_ARGS+= \
        --without-sdl-prefix \
        --without-cppunit-prefix \
 
-CONFIGURE_VARS+= \
-       CXX="g++-uc+std" \
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
index 1341838..7a0d720 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aMule
 PKG_VERSION:=2.1.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/amule
@@ -65,9 +65,6 @@ CONFIGURE_ARGS+= \
        --without-libintl-prefix \
        --without-x \
 
-CONFIGURE_VARS+= \
-       CXX="g++-uc+std" \
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                HOSTCC="$(HOSTCC)" \
index a8b4813..bbe22e1 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mutella
 PKG_VERSION:=0.4.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
@@ -26,7 +26,7 @@ define Package/mutella
   CATEGORY:=Network
   TITLE:=Gnutella client with command line and http interface
   URL:=http://mutella.sourceforge.net/
-  DEPENDS:=+libncurses +libreadline +libpthread +uclibcxx +zlib
+  DEPENDS:=+libncurses +libreadline +libpthread +libstdcpp +zlib
 endef
 
 define Package/mutella/description
@@ -41,7 +41,6 @@ define Package/mutella/description
 endef
 
 CONFIGURE_VARS += \
-       CXX="g++-uc+std" \
        CXXFLAGS="$$$$CXXFLAGS -fno-rtti"  \
 
 define Build/Prepare
index ba596a5..cdcf604 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rtorrent
 PKG_VERSION:=0.7.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://libtorrent.rakshasa.no/downloads/
@@ -30,10 +30,10 @@ define Package/rtorrent
 endef
 
 define Package/rtorrent/description
      rTorrent is a BitTorrent client for ncurses, using the libtorrent library.
      The client and library are written in C++ with emphasis on speed and
      efficiency, while delivering equivalent features to those found in GUI
      based clients in an ncurses client.
+ rTorrent is a BitTorrent client for ncurses, using the libtorrent library.
+ The client and library are written in C++ with emphasis on speed and
+ efficiency, while delivering equivalent features to those found in GUI
+ based clients in an ncurses client.
 endef
 
 CONFIGURE_ARGS+= \
@@ -42,17 +42,18 @@ CONFIGURE_ARGS+= \
        --disable-debug \
 
 CONFIGURE_VARS += \
-       CXX="g++-uc+std" \
        CXXFLAGS="$$$$CXXFLAGS -fno-rtti"  \
        LIBS="-lm" \
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
 endef
 
 define Package/rtorrent/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/rtorrent $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/rtorrent $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,rtorrent))