packages/oidentd: use new service functions
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Nov 2011 23:43:26 +0000 (23:43 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Nov 2011 23:43:26 +0000 (23:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28913 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/oidentd/Makefile
net/oidentd/files/oidentd.init

index ef60431..9959c5f 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oidentd
 PKG_VERSION:=2.0.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ojnk
index 2bdc34d..4b4f309 100644 (file)
@@ -1,11 +1,12 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 
 START=85
+
 start() {
-       /usr/sbin/oidentd -m -f 113
+       service_start /usr/sbin/oidentd -m -f 113
 }
 
 stop() {
-       killall oidentd
+       service_stop /usr/sbin/oidentd
 }