[packages] multiwan: Updated failover removal
authorcraigc <craigc@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 26 Apr 2010 18:54:10 +0000 (18:54 +0000)
committercraigc <craigc@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 26 Apr 2010 18:54:10 +0000 (18:54 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@21176 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/multiwan/Makefile
net/multiwan/files/usr/bin/multiwan

index 1bc7a9b..cbe8675 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=multiwan
-PKG_VERSION:=1.0l
-PKG_RELEASE:=2
+PKG_VERSION:=1.0m
+PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
 
index 1d610f5..5b2ba76 100755 (executable)
@@ -40,11 +40,7 @@ fi
 
 del() {
 if [ "$existing_failover" == "3" ]; then
-       if [ "$failover_to" != "balancer" -a "failover_to" != "disable" -a "$failover_to_wanid" != "$wanid" ]; then
-               iptables -D FW${wanid}MARK -t mangle -j FW${failover_to_wanid}MARK
-       elif [ "$failover_to" == "balancer" ]; then
-               iptables -D FW${wanid}MARK -t mangle -j LoadBalancer
-       fi
+               iptables -D FW${wanid}MARK 2 -t mangle
 fi
         mwnote "$1 has recovered and is back online!"
 }