[packages] restorefactory: update to release 5
authornunojpg <nunojpg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Jan 2011 15:34:05 +0000 (15:34 +0000)
committernunojpg <nunojpg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Jan 2011 15:34:05 +0000 (15:34 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@24910 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/restorefactory/Makefile
utils/restorefactory/files/uci_defaults_restorefactory

index 5823df2..a3fda80 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=restorefactory
 PKG_VERSION:=1
-PKG_RELEASE:=3
+PKG_RELEASE:=5
 
 include $(INCLUDE_DIR)/package.mk
 
index ad27b48..558bbd6 100755 (executable)
@@ -1,6 +1,10 @@
 #!/bin/sh
-uci add system restorefactory
-uci set system.@restorefactory[0].button=reset
-uci set system.@restorefactory[0].action=pressed
-uci set system.@restorefactory[0].timeout=5
-uci commit
+
+[ -n "$(uci -q show system.@restorefactory[0])" ] || {
+       uci add system restorefactory
+       uci set system.@restorefactory[0].button=reset
+       uci set system.@restorefactory[0].action=pressed
+       uci set system.@restorefactory[0].timeout=5
+       uci commit
+}
+