[packages] ddns-scripts: add he.net service url (#9376)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 9 May 2011 07:11:18 +0000 (07:11 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 9 May 2011 07:11:18 +0000 (07:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26863 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/ddns-scripts/Makefile
net/ddns-scripts/files/usr/lib/ddns/services

index 19240e9..108627b 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ddns-scripts
 PKG_VERSION:=1.0.0
-PKG_RELEASE:=13
+PKG_RELEASE:=14
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
index 3430113..25ecc1d 100644 (file)
@@ -20,7 +20,6 @@
 #freedns.afraid.org is weird, you just need an update code, for which we use the password variable
 "freedns.afraid.org"   "http://freedns.afraid.org/dynamic/update.php?[PASSWORD]"
 
-
 #### ADD YOURS HERE! ######################################################################################
 #                                                                                                         #
 # There are TONS of dynamic dns services out there. There's a huge list of them at:                       #
@@ -30,5 +29,8 @@
 ###########################################################################################################
 
 # DNS Max and resellers' update urls
-"dnsmax.com" "http://update.dnsmax.com/update/?username=[USERNAME]&password=[PASSWORD]&resellerid=1&clientname=openwrt&clientversion=8.09&protocolversion=2.0&updatehostname=[DOMAIN]&ip=[IP]"
-"thatip.com" "http://update.dnsmax.com/update/?username=[USERNAME]&password=[PASSWORD]&resellerid=2&clientname=openwrt&clientversion=8.09&protocolversion=2.0&updatehostname=[DOMAIN]&ip=[IP]"
+"dnsmax.com"   "http://update.dnsmax.com/update/?username=[USERNAME]&password=[PASSWORD]&resellerid=1&clientname=openwrt&clientversion=8.09&protocolversion=2.0&updatehostname=[DOMAIN]&ip=[IP]"
+"thatip.com"   "http://update.dnsmax.com/update/?username=[USERNAME]&password=[PASSWORD]&resellerid=2&clientname=openwrt&clientversion=8.09&protocolversion=2.0&updatehostname=[DOMAIN]&ip=[IP]"
+
+# Hurricane Electric Dynamic DNS
+"he.net"               "http://[DOMAIN]:[PASSWORD]@dyn.dns.he.net/nic/update?hostname=[DOMAIN]&myip=[IP]"