[packages] tftp-hpa: Add missing libreadline dependency, disable tcpwrappers, bump...
authoracinonyx <acinonyx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 14 Aug 2009 13:25:19 +0000 (13:25 +0000)
committeracinonyx <acinonyx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 14 Aug 2009 13:25:19 +0000 (13:25 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17255 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/tftp-hpa/Makefile

index 57a253e..0adddf1 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tftp-hpa
 PKG_VERSION:=0.48
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@KERNEL/software/network/tftp
@@ -20,6 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/tftp-hpa/Default
   SECTION:=net
   CATEGORY:=Network
+  DEPENDS:=+libreadline
   URL:=http://www.kernel.org/pub/software/network/tftp
 endef
 
@@ -35,7 +36,7 @@ endef
 
 define Build/Configure 
        $(call Build/Configure/Default, \
-               , \
+               --without-tcpwrappers, \
                CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
        )
 endef