keepalived: moved to github
[packages.git] / libs / check / Makefile
index 1dc0b5c..5444079 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,34 +8,34 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=check
-PKG_VERSION:=0.9.5
+PKG_VERSION:=0.9.8
 PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://dl.sourceforge.net/sourceforge/check/
-PKG_FIXUP:=libtool
 
-include $(INCLUDE_DIR)/package.mk
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/check
+PKG_MD5SUM:=5d75e9a6027cde79d2c339ef261e7470
 
-PKG_INSTALL = 1
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
 
-TARGET_CFLAGS += $(FPIC) \
-       -I$(STAGING_DIR)/usr/lib/libintl/include \
-       -I$(STAGING_DIR)/usr/lib/libiconv/include
+include $(INCLUDE_DIR)/package.mk
 
-TARGET_LDFLAGS += \
-       -L$(STAGING_DIR)/usr/lib/libintl/lib \
-       -L$(STAGING_DIR)/usr/lib/libiconv/lib
+TARGET_CFLAGS += $(FPIC)
 
 define Package/check
-  SECTION:=lib
+  SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=check
-  URL:=http://sf.net
-  DEPENDS:=+libxml2
+  TITLE:=Unit testing framework for C
+  URL:=http://check.sourceforge.net/
+  DEPENDS:= +libpthread
 endef
 
 define Package/check/description
-  unit testing library
+  Check features a simple interface for defining unit tests, putting little in
+  the way of the developer. Tests are run in a separate address space, so Check
+  can catch both assertion failures and code errors that cause segmentation
+  faults or other signals. The output from unit tests can be used within source
+  code editors and IDEs.
 endef
 
 define Build/Configure
@@ -45,17 +45,17 @@ endef
 
 define Build/Install
        $(call Build/Install/Default)
-       cd $(PKG_INSTALL_DIR)/usr/lib/ ; ln -s libcheck.so libcheck_pic.so
+       cd $(PKG_INSTALL_DIR)/usr/lib/ ; ln -nsf libcheck.so libcheck_pic.so
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)
-       cp -r $(PKG_INSTALL_DIR)/* $(1)
+       $(INSTALL_DIR) $(1)
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
 endef
 
 define Package/check/install
-       mkdir -p $(1)
-       cp -r $(PKG_INSTALL_DIR)/* $(1)
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcheck.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,check))