AA: backport r36655 from trunk
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 24 May 2013 15:11:24 +0000 (15:11 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 24 May 2013 15:11:24 +0000 (15:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@36715 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/dnsmasq/Makefile
package/dnsmasq/files/dnsmasq.init

index 4ad0f37..baa48d5 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.62
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
index 85c22c3..5d5d97f 100644 (file)
@@ -133,6 +133,9 @@ dnsmasq() {
        config_get hostsfile "$cfg" dhcphostsfile
        [ -e "$hostsfile" ] && xappend "--dhcp-hostsfile=$hostsfile"
 
+       mkdir -p /tmp/hosts
+       xappend "--addn-hosts=/tmp/hosts"
+
        local rebind
        config_get_bool rebind "$cfg" rebind_protection 1
        [ $rebind -gt 0 ] && {