AA: uhttpd: fix build error with the new json-c (#13690)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 12 Jun 2013 10:16:47 +0000 (10:16 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 12 Jun 2013 10:16:47 +0000 (10:16 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@36924 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/uhttpd/patches/100-json_c.patch [new file with mode: 0644]

diff --git a/package/uhttpd/patches/100-json_c.patch b/package/uhttpd/patches/100-json_c.patch
new file mode 100644 (file)
index 0000000..06671fc
--- /dev/null
@@ -0,0 +1,15 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -62,10 +62,11 @@ ELSE()
+       MESSAGE(FATAL_ERROR "Invalid TLS provider option, use none|openssl|cyassl")
+ ENDIF()
++FIND_LIBRARY(json json-c json)
+ IF(UBUS_SUPPORT)
+       ADD_DEFINITIONS(-DHAVE_UBUS)
+       ADD_LIBRARY(uhttpd_ubus MODULE uhttpd-ubus.c)
+-      TARGET_LINK_LIBRARIES(uhttpd_ubus ubox ubus json blobmsg_json)
++      TARGET_LINK_LIBRARIES(uhttpd_ubus ubox ubus ${json} blobmsg_json)
+       SET(PLUGINS ${PLUGINS} uhttpd_ubus)
+ ENDIF()