rename interface-hotplug.c to interface-event.c
[project/netifd.git] / CMakeLists.txt
index 8fb8ae1..461c07c 100644 (file)
@@ -11,14 +11,15 @@ IF(APPLE)
 ENDIF()
 
 SET(SOURCES
-       main.c utils.c interface.c interface-ip.c
+       main.c utils.c
+       interface.c interface-ip.c interface-event.c
        proto.c proto-static.c proto-shell.c
        config.c device.c bridge.c vlan.c ubus.c)
 
 SET(LIBS
        ubox ubus uci json blobmsg_json)
 
-IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
+IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux" AND NOT DUMMY_MODE)
        SET(SOURCES ${SOURCES} system-linux.c)
        SET(LIBS ${LIBS} nl)
 ELSE()