contrib/package/sysupgrade-atheros: fix postinstall
[project/luci.git] / contrib / package / sysupgrade-atheros / Makefile
index 6b52ee1..7b20d85 100644 (file)
@@ -18,7 +18,7 @@ define Package/sysupgrade-atheros
   CATEGORY:=LuCI
   SUBMENU:=Freifunk
   TITLE:=Experimental sysupgrade support for Atheros SoC
-  DEPENDS:=+base-files
+  DEPENDS:=@TARGET_atheros +base-files
 endef
 
 define Package/sysupgrade-atheros/description
@@ -40,10 +40,8 @@ endef
 define Package/sysupgrade-atheros/postinst
 #!/bin/sh
 [ -n "$${IPKG_INSTROOT}" ] || {
-  if ! grep -q /etc/firewall.freifunk /etc/config/firewall; then
-    uci add firewall include >/dev/null
-    uci set firewall.@include[-1].path=/etc/firewall.freifunk
-    uci commit firewall
+  if [ -f /lib/upgrade/kill-ffwatchd.sh ]; then
+    rm -f /lib/upgrade/kill-ffwatchd.sh
   fi
 }
 endef