contrib: remove luci-light collection, throw out admin-mini of default collection...
[project/luci.git] / contrib / package / luci / Makefile
index 9de1317..f8bb81e 100644 (file)
@@ -9,6 +9,8 @@ endif
 PKG_NAME:=luci
 PKG_RELEASE:=1
 
+PKG_BUILD_PARALLEL:=0
+
 ifeq ($(USELOCAL),1)
   PKG_VERSION:=0.10+svn
 else
@@ -29,14 +31,13 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 LUA_TARGET:=source
 LUCI_CFLAGS:=
-PKG_SELECTED_MODULES:=
+LUCI_BUILD_PACKAGES:=
+LUCI_SELECTED_MODULES:=
 
 ifeq ($(BOARD),brcm-2.4)
   MAKE_FLAGS += CRAP="1"
 endif
 
-BUILD_PACKAGES:=
-
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -55,7 +56,7 @@ define Build/Configure
 endef
 
 MAKE_FLAGS += \
-       MODULES="$(PKG_SELECTED_MODULES)" \
+       MODULES="$(LUCI_SELECTED_MODULES)" \
        LUA_TARGET="$(LUA_TARGET)" \
        LUA_SHLIBS="-llua -lm -ldl -lcrypt" \
        CFLAGS="$(TARGET_CFLAGS) $(LUCI_CFLAGS) -I$(STAGING_DIR)/usr/include" \
@@ -78,7 +79,7 @@ define Package/luci-lib-core
   URL:=http://luci.subsignal.org/
   MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
   SUBMENU:=Libraries
-  DEPENDS:=+lua
+  DEPENDS:=+lua +libuci-lua
   TITLE:=LuCI core libraries
 endef
 
@@ -121,10 +122,10 @@ ifneq ($(CONFIG_PACKAGE_luci-lib-core_zipped),)
 endif
 
 ifneq ($(CONFIG_PACKAGE_luci-lib-core),)
-  PKG_SELECTED_MODULES+=libs/core
+  LUCI_SELECTED_MODULES+=libs/core
 endif
 
-BUILD_PACKAGES += luci-lib-core
+LUCI_BUILD_PACKAGES += luci-lib-core
 
 
 ### Libraries ###
@@ -146,14 +147,10 @@ define library
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-lib-$(1)),)
-    PKG_SELECTED_MODULES+=libs/$(1)
+    LUCI_SELECTED_MODULES+=libs/$(1)
   endif
 
-  BUILD_PACKAGES += luci-lib-$(1)
-endef
-
-define Package/luci-lib-lucid/extra-install
-       $(call Package/luci/install/template,$(1),libs/lucid-http)
+  LUCI_BUILD_PACKAGES += luci-lib-$(1)
 endef
 
 define Package/luci-lib-web/conffiles
@@ -203,8 +200,9 @@ $(eval $(call library,httpclient,HTTP(S) client library,+luci-lib-web +luci-lib-
 $(eval $(call library,ipkg,LuCI IPKG/OPKG call abstraction library))
 $(eval $(call library,json,LuCI JSON library))
 $(eval $(call library,lmo,LuCI LMO I18N library))
-$(eval $(call library,luanet,LuCI luanet library,+libiw))
 $(eval $(call library,lucid,LuCId Full-Stack Webserver,+luci-lib-nixio +luci-lib-web +luci-lib-px5g))
+$(eval $(call library,lucid-http,LuCId HTTP Backend,+luci-lib-lucid))
+$(eval $(call library,lucid-rpc,LuCId RPC Backend,+luci-lib-lucid))
 $(eval $(call library,nixio,NIXIO POSIX library,+PACKAGE_luci-lib-nixio_openssl:libopenssl +PACKAGE_luci-lib-nixio_cyassl:libcyassl))
 $(eval $(call library,px5g,RSA/X.509 Key Generator (required for LuCId SSL support),+luci-lib-nixio))
 $(eval $(call library,sys,LuCI Linux/POSIX system library,+libiwinfo))
@@ -236,10 +234,10 @@ define Package/luci-mod-freifunk-community/install
 endef
 
 ifneq ($(CONFIG_PACKAGE_luci-mod-freifunk-community),)
-       PKG_SELECTED_MODULES+=applications/freifunk-community
+       LUCI_SELECTED_MODULES+=applications/freifunk-community
 endif
 
-BUILD_PACKAGES += luci-mod-freifunk-community
+LUCI_BUILD_PACKAGES += luci-mod-freifunk-community
 
 
 ### Modules ###
@@ -261,10 +259,10 @@ define module
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-mod-$(1)),)
-    PKG_SELECTED_MODULES+=modules/$(1)
+    LUCI_SELECTED_MODULES+=modules/$(1)
   endif
 
-  BUILD_PACKAGES += luci-mod-$(1)
+  LUCI_BUILD_PACKAGES += luci-mod-$(1)
 endef
 
 
@@ -302,10 +300,10 @@ define application
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-app-$(1)),)
-    PKG_SELECTED_MODULES+=applications/luci-$(1)
+    LUCI_SELECTED_MODULES+=applications/luci-$(1)
   endif
 
-  BUILD_PACKAGES += luci-app-$(1)
+  LUCI_BUILD_PACKAGES += luci-app-$(1)
 endef
 
 define Package/luci-app-splash/conffiles
@@ -362,7 +360,7 @@ $(eval $(call application,diag-devinfo,LuCI Diagnostics Tools (Device Info),\
 
 $(eval $(call application,voice-core,LuCI Voice Software (Core)))
 
-$(eval $(call application,voide-diag,LuCI Voice Software (Diagnostics),\
+$(eval $(call application,voice-diag,LuCI Voice Software (Diagnostics),\
        +luci-app-voice-core +luci-app-diag-devinfo))
 
 
@@ -421,6 +419,7 @@ $(eval $(call application,vnstat,LuCI Support for VnStat,\
        +PACKAGE_luci-app-vnstat:vnstat \
     +PACKAGE_luci-app-vnstat:vnstati))
 
+$(eval $(call application,lqtapifoss,Lantiq voip))
 
 ### Server Gateway Interfaces ###
 define sgi
@@ -440,10 +439,10 @@ define sgi
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-sgi-$(1)),)
-    PKG_SELECTED_MODULES+=libs/sgi-$(1)
+    LUCI_SELECTED_MODULES+=libs/sgi-$(1)
   endif
 
-  BUILD_PACKAGES += luci-sgi-$(1)
+  LUCI_BUILD_PACKAGES += luci-sgi-$(1)
 endef
 
 $(eval $(call sgi,cgi,CGI Gateway behind existing Webserver))
@@ -460,7 +459,7 @@ define theme
     SUBMENU:=Themes
     TITLE:=$(if $(2),$(2),LuCI $(1) theme)
        MAINTAINER:=$(if $(3),$(3),LuCI Development Team <luci@lists.subsignal.org>)
-       DEPENDS:=$(ifneq $(1),base,+luci-theme-base) $(4)
+       DEPENDS:=$(if $(filter-out base,$(1)),+luci-theme-base) $(4)
        $(if $(5),DEFAULT:=y if PACKAGE_luci-lib-core)
   endef
 
@@ -469,15 +468,14 @@ define theme
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-theme-$(1)),)
-    PKG_SELECTED_MODULES+=themes/$(1)
+    LUCI_SELECTED_MODULES+=themes/$(1)
   endif
 
-  BUILD_PACKAGES += luci-theme-$(1)
+  LUCI_BUILD_PACKAGES += luci-theme-$(1)
 endef
 
 $(eval $(call theme,base,Common base for all themes,,+luci-lib-web))
 $(eval $(call theme,openwrt,OpenWrt.org (default),,,1))
-$(eval $(call theme,openwrtlight,OpenWrt.org - light variant without images))
 $(eval $(call theme,fledermaus,Fledermaus Theme))
 
 $(eval $(call theme,freifunk,alternative Freifunk Theme,\
@@ -507,10 +505,10 @@ define translation
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-i18n-$(1)),)
-    PKG_SELECTED_MODULES+=i18n/$(1)
+    LUCI_SELECTED_MODULES+=i18n/$(1)
   endif
 
-  BUILD_PACKAGES += luci-i18n-$(1)
+  LUCI_BUILD_PACKAGES += luci-i18n-$(1)
 endef
 
 $(eval $(call translation,german,German))
@@ -546,28 +544,24 @@ define collection
        true
   endef
 
-  BUILD_PACKAGES += luci$(if $(1),-$(1))
+  LUCI_BUILD_PACKAGES += luci$(if $(1),-$(1))
 endef
 
 $(eval $(call collection,,\
        Standard OpenWrt set including full and mini admin and the standard theme,\
-       +uhttpd +luci-mod-admin-full +luci-mod-admin-mini +luci-theme-openwrt \
-    +luci-app-firewall +luci-app-initmgr))
+       +uhttpd +luci-mod-admin-full +luci-theme-openwrt +luci-app-firewall \
+       +luci-app-initmgr))
 
 $(eval $(call collection,ssl,\
        Standard OpenWrt set with HTTPS support,\
-       +uhttpd +uhttpd-mod-tls +px5g +luci-mod-admin-full +luci-mod-admin-mini \
-    +luci-theme-openwrt +luci-app-firewall +luci-app-initmgr))
-
-$(eval $(call collection,medium,\
-       Medium package set using only admin full and a theme without graphics,\
-       +uhttpd +luci-mod-admin-full +luci-theme-openwrtlight))
+       +uhttpd +uhttpd-mod-tls +px5g +luci-mod-admin-full +luci-theme-openwrt \
+       +luci-app-firewall +luci-app-initmgr))
 
 $(eval $(call collection,light,\
-       Minimum package set using only admin mini and a theme without graphics,\
-       +uhttpd +luci-mod-admin-mini +luci-theme-openwrtlight))
+       Minimum package set using only admin mini and athe standard theme,\
+       +uhttpd +luci-mod-admin-mini +luci-theme-openwrt-light))
 
 
 ### Compile ###
-PKG_CONFIG_DEPENDS := $(patsubst %,CONFIG_PACKAGE_%,$(BUILD_PACKAGES))
-$(foreach b,$(BUILD_PACKAGES),$(eval $(call BuildPackage,$(b))))
+PKG_CONFIG_DEPENDS := $(patsubst %,CONFIG_PACKAGE_%,$(LUCI_BUILD_PACKAGES))
+$(foreach b,$(LUCI_BUILD_PACKAGES),$(eval $(call BuildPackage,$(b))))