contrib/package/olsrd-luci: remove garbage from 140-olsrd-optimize-size.patch
[project/luci.git] / contrib / package / luci / Makefile
index 6dad6d4..dd79fdd 100644 (file)
@@ -14,7 +14,7 @@ ifeq ($(USELOCAL),1)
 else
   PKG_SOURCE_URL:=http://svn.luci.subsignal.org/luci/$(PKG_BRANCH)
   ifeq ($(DUMP),)
-    PKG_REV:=$(shell LC_ALL=C svn info ${PKG_SOURCE_URL} | sed -ne's/^Last Changed Rev: //p')
+    PKG_REV:=$(shell LC_ALL=C svn info ${PKG_SOURCE_URL} | sed -ne's/^Revision: //p')
     PKG_VERSION:=0.9+svn$(PKG_REV)
   endif
   PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
@@ -309,8 +309,8 @@ define Package/luci-freifunk-community
    +luci-i18n-german \
    +PACKAGE_luci-freifunk-community:olsrd-luci +PACKAGE_luci-freifunk-community:olsrd-luci-mod-dyn-gw-plain \
    +PACKAGE_luci-freifunk-community:olsrd-luci-mod-txtinfo +PACKAGE_luci-freifunk-community:olsrd-luci-mod-nameservice \
-   +PACKAGE_luci-freifunk-community:kmod-tun +PACKAGE_luci-freifunk-community:ip \
-   +luci-app-olsr
+   +PACKAGE_luci-freifunk-community:olsrd-luci-mod-watchdog +PACKAGE_luci-freifunk-community:kmod-tun \
+   +PACKAGE_luci-freifunk-community:ip +luci-app-olsr
   TITLE:=Freifunk Community Meta-Package
 endef
 
@@ -463,7 +463,7 @@ define Package/luci-app-statistics
    +PACKAGE_luci-app-statistics:rrdtool1 \
    +PACKAGE_luci-app-statistics:collectd-mod-rrdtool1 \
    +PACKAGE_luci-app-statistics:collectd-mod-wireless \
-   +PACKAGE_luci-app-statistics:collectd-mod-interfaces \
+   +PACKAGE_luci-app-statistics:collectd-mod-interface \
    +PACKAGE_luci-app-statistics:collectd-mod-load
   TITLE:=LuCI Statistics Application
 endef