contrib/package: add option to disable nixio tls support
[project/luci.git] / contrib / package / luci / Makefile
index a598d98..7666d04 100644 (file)
@@ -275,7 +275,7 @@ endef
 
 
 
-NIXIO_TLS:=axtls
+NIXIO_TLS:=
 
 define Package/luci-nixio
   $(call Package/luci/libtemplate)
@@ -290,7 +290,10 @@ endef
 define Package/luci-nixio/config
        choice
                prompt "TLS Provider"
-               default PACKAGE_luci-nixio_axtls
+               default PACKAGE_luci-nixio_notls
+
+               config PACKAGE_luci-nixio_notls
+                       bool "Disabled"
 
                config PACKAGE_luci-nixio_axtls
                        bool "Builtin (axTLS)"
@@ -305,6 +308,10 @@ define Package/luci-nixio/config
        endchoice
 endef
 
+ifneq ($(CONFIG_PACKAGE_luci-nixio_axtls),)
+  NIXIO_TLS:=axtls
+endif
+
 ifneq ($(CONFIG_PACKAGE_luci-nixio_openssl),)
   NIXIO_TLS:=openssl
 endif
@@ -775,7 +782,7 @@ endef
 define Package/luci-sgi-uhttpd
   $(call Package/luci/webservertemplate)
   TITLE:=Binding for the uHTTPd server
-  DEPENDS+=+uhttpd +px5g
+  DEPENDS+=+uhttpd +uhttpd-mod-tls +uhttpd-mod-lua +px5g
 endef
 
 define Package/luci-sgi-uhttpd/install
@@ -786,7 +793,7 @@ endef
 ### Themes ###
 define Package/luci-theme-base
   $(call Package/luci/thtemplate)
-  DEPENDS:=+luci-web
+  DEPENDS:=
   TITLE:=Common base for all themes
 endef