Overall CBI-UVL ineraction fixes
[project/luci.git] / contrib / package / luci / Makefile
index d2c0603..725e394 100644 (file)
@@ -10,12 +10,12 @@ PKG_NAME:=luci
 PKG_RELEASE:=1
 
 ifeq ($(USELOCAL),1)
-  PKG_VERSION:=0.7+svn
+  PKG_VERSION:=0.9+svn
 else
   PKG_SOURCE_URL:=http://dev.leipzig.freifunk.net/svn/ff-luci/$(PKG_BRANCH)
   ifeq ($(DUMP),)
     PKG_REV:=$(shell LC_ALL=C svn info ${PKG_SOURCE_URL} | sed -ne's/^Last Changed Rev: //p')
-    PKG_VERSION:=0.7+svn$(PKG_REV)
+    PKG_VERSION:=0.9+svn$(PKG_REV)
   endif
   PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
   PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
@@ -104,7 +104,7 @@ define Package/luci-core
   TITLE:=LuCI core libraries
 endef
 
-define Package/luci-core/install               
+define Package/luci-core/install
        $(call Package/luci/install/template,$(1),libs/core)
 endef
 
@@ -115,7 +115,7 @@ define Package/luci-core/config
 
        config PACKAGE_luci-core_compile
                bool "Precompiled"
-               
+
        config PACKAGE_luci-core_stripped
                bool "Stripped"
 
@@ -137,7 +137,7 @@ endif
 ### Libraries ###
 define Package/luci-cbi
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-web
+  DEPENDS+=+luci-web +luci-uvl +luci-uci
   TITLE:=Configuration Binding Interface
 endef
 
@@ -179,7 +179,7 @@ endef
 
 define Package/luci-ipkg
   $(call Package/luci/libtemplate)
-  TITLE:=LuCI IPKG/OPKG call abstraction library 
+  TITLE:=LuCI IPKG/OPKG call abstraction library
 endef
 
 define Package/luci-ipkg/install
@@ -187,6 +187,16 @@ define Package/luci-ipkg/install
 endef
 
 
+define Package/luci-json
+  $(call Package/luci/libtemplate)
+  TITLE:=LuCI JSON Library
+endef
+
+define Package/luci-json/install
+       $(call Package/luci/install/template,$(1),libs/json)
+endef
+
+
 define Package/luci-sys
   $(call Package/luci/libtemplate)
   TITLE:=LuCI Linux/POSIX system library
@@ -212,6 +222,17 @@ define Package/luci-web/install
 endef
 
 
+define Package/luci-uvl
+  $(call Package/luci/libtemplate)
+  DEPENDS+=+luci-sys +luci-uci +luci-core
+  TITLE:=UVL - UCI Validation Layer
+endef
+
+define Package/luci-uvl/install
+       $(call Package/luci/install/template,$(1),libs/uvl)
+endef
+
+
 
 ### HTTPD ###
 
@@ -236,7 +257,7 @@ define Package/luci-ff-halle
    +luci-app-ffwizard-leipzig \
    +luci-theme-fledermaus \
    +luci-i18n-german \
-   +olsrd +olsrd-mod-dyn-gw +olsrd-mod-txtinfo +olsrd-mod-nameservice \
+   +olsrd-luci +olsrd-luci-mod-dyn-gw +olsrd-luci-mod-txtinfo +olsrd-luci-mod-nameservice \
    +kmod-tun +ip
   TITLE:=Freifunk Halle Community Meta-Package
 endef
@@ -253,7 +274,7 @@ define Package/luci-ff-leipzig
    +luci-app-ffwizard-leipzig \
    +luci-theme-fledermaus \
    +luci-i18n-german \
-   +olsrd +olsrd-mod-dyn-gw +olsrd-mod-txtinfo +olsrd-mod-nameservice \
+   +olsrd-luci +olsrd-luci-mod-dyn-gw +olsrd-luci-mod-txtinfo +olsrd-luci-mod-nameservice \
    +kmod-tun +ip
   TITLE:=Freifunk Leipzig Community Meta-Package
 endef
@@ -269,7 +290,7 @@ define Package/luci-ff-hannover
    +luci-sgi-cgi +luci-app-splash +luci-app-olsr \
    +luci-theme-fledermaus \
    +luci-i18n-german \
-   +olsrd +olsrd-mod-dyn-gw +olsrd-mod-txtinfo +olsrd-mod-nameservice
+   +olsrd-luci +olsrd-luci-mod-dyn-gw +olsrd-luci-mod-txtinfo +olsrd-luci-mod-nameservice
   TITLE:=Freifunk Hannover Community Meta-Package
   URL:=http://www.freifunk-hannover.de/
   MAINTAINER:=Mickey Knox <mickey-at-netfreaks-dot-org>
@@ -286,7 +307,7 @@ define Package/luci-ff-berlin
    +luci-sgi-cgi +luci-app-splash +luci-app-olsr \
    +luci-theme-fledermaus \
    +luci-i18n-german \
-   +olsrd +olsrd-mod-dyn-gw +olsrd-mod-txtinfo +olsrd-mod-nameservice
+   +olsrd-luci +olsrd-luci-mod-dyn-gw +olsrd-luci-mod-txtinfo +olsrd-luci-mod-nameservice
   TITLE:=Freifunk Berlin Community Meta-Package
 endef
 
@@ -300,7 +321,7 @@ define Package/luci-ff-augsburg
    +luci-sgi-cgi +luci-app-splash +luci-app-olsr \
    +luci-theme-fledermaus \
    +luci-i18n-german \
-   +olsrd +olsrd-mod-dyn-gw +olsrd-mod-txtinfo +olsrd-mod-nameservice
+   +olsrd-luci +olsrd-luci-mod-dyn-gw +olsrd-luci-mod-txtinfo +olsrd-luci-mod-nameservice
   TITLE:=Freifunk Augsburg Community Meta-Package
 endef
 
@@ -324,7 +345,7 @@ endef
 define Package/luci-admin-mini
   $(call Package/luci/webtemplate)
   DEPENDS+=+luci-admin-core
-  TITLE:=LuCI Essentials - casual user's interface
+  TITLE:=LuCI Essentials - stripped down and user-friendly
 endef
 
 define Package/luci-admin-mini/install
@@ -335,7 +356,7 @@ endef
 define Package/luci-admin-full
   $(call Package/luci/webtemplate)
   DEPENDS+=+luci-admin-core +luci-ipkg
-  TITLE:=LuCI Administration - power user's interface
+  TITLE:=LuCI Administration - full-featured for full control
 endef
 
 define Package/luci-admin-full/install
@@ -343,6 +364,17 @@ define Package/luci-admin-full/install
 endef
 
 
+define Package/luci-admin-rpc
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-json
+  TITLE:=LuCI RPC - JSON-RPC API
+endef
+
+define Package/luci-admin-rpc/install
+       $(call Package/luci/install/template,$(1),modules/rpc)
+endef
+
+
 define Package/luci-mod-freifunk
   $(call Package/luci/fftemplate)
   DEPENDS:=+luci-admin-full
@@ -363,7 +395,6 @@ endef
 
 define Package/luci-app-ffwizard-leipzig
   $(call Package/luci/fftemplate)
-  DEPENDS+=+luci-app-firewall
   TITLE:=Freifunk Leipzig configuration wizard
 endef
 
@@ -374,7 +405,7 @@ endef
 
 define Package/luci-app-firewall
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-core +firewall
+  DEPENDS+=+luci-admin-core
   TITLE:=Firewall and Portforwarding application
 endef
 
@@ -385,7 +416,7 @@ endef
 
 define Package/luci-app-olsr
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +olsrd +olsrd-mod-txtinfo
+  DEPENDS+=+luci-admin-full +olsrd-luci +olsrd-luci-mod-txtinfo
   TITLE:=OLSR configuration and status module
 endef
 
@@ -407,7 +438,7 @@ endef
 
 define Package/luci-app-splash
   $(call Package/luci/fftemplate)
-  DEPENDS+=+luasocket +firewall
+  DEPENDS+=+luasocket
   TITLE:=Freifunk DHCP-Splash application
 endef
 
@@ -470,7 +501,7 @@ endef
 
 define Package/luci-app-samba
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +samba
+  DEPENDS+=+luci-admin-full +samba3
   TITLE:=Network Shares - Samba SMB/CIFS module
 endef
 
@@ -479,6 +510,18 @@ define Package/luci-app-samba/install
 endef
 
 
+define Package/luci-app-uvc_streamer
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full +uvc-streamer
+  TITLE:=Webcam Streaming - UVC-Streamer module
+endef
+
+define Package/luci-app-uvc_streamer/install
+        $(call Package/luci/install/template,$(1),applications/luci-uvc_streamer)
+endef
+
+
+
 ### Server Gateway Interfaces ###
 
 define Package/luci-sgi-cgi
@@ -529,6 +572,16 @@ define Package/luci-theme-openwrt/install
        $(call Package/luci/install/template,$(1),themes/openwrt.org)
 endef
 
+define Package/luci-theme-openwrtlight
+  $(call Package/luci/thtemplate)
+  TITLE:=OpenWRT.org - light variant without images
+endef
+
+define Package/luci-theme-openwrtlight/install
+       $(call Package/luci/install/template,$(1),themes/openwrt-light)
+endef
+
+
 ### Translations ###
 define Package/luci-i18n-german
   $(call Package/luci/i18ntemplate)
@@ -552,7 +605,7 @@ endef
 
 define Package/luci-i18n-french
   $(call Package/luci/i18ntemplate)
-  TITLE:=French
+  TITLE:=French (by Florian Fainelli)
 endef
 
 define Package/luci-i18n-french/install
@@ -560,6 +613,15 @@ define Package/luci-i18n-french/install
 endef
 
 
+define Package/luci-i18n-russian
+  $(call Package/luci/i18ntemplate)
+  TITLE:=Russian (by Skryabin Dmitry)
+endef
+
+define Package/luci-i18n-russian/install
+       $(call Package/luci/install/template,$(1),i18n/russian)
+endef
+
 
 
 ### Compile ###
@@ -578,6 +640,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-ipkg),)
        PKG_SELECTED_MODULES+=libs/ipkg
 endif
+ifneq ($(CONFIG_PACKAGE_luci-json),)
+       PKG_SELECTED_MODULES+=libs/json
+endif
 ifneq ($(CONFIG_PACKAGE_luci-uci),)
        PKG_SELECTED_MODULES+=libs/uci
 endif
@@ -587,6 +652,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-web),)
        PKG_SELECTED_MODULES+=libs/web
 endif
+ifneq ($(CONFIG_PACKAGE_luci-uvl),)
+       PKG_SELECTED_MODULES+=libs/uvl
+endif
 
 ifneq ($(CONFIG_PACKAGE_luci-httpd),)
        PKG_SELECTED_MODULES+=libs/httpd
@@ -617,6 +685,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-admin-full),)
        PKG_SELECTED_MODULES+=modules/admin-full
 endif
+ifneq ($(CONFIG_PACKAGE_luci-admin-rpc),)
+       PKG_SELECTED_MODULES+=modules/rpc
+endif
 ifneq ($(CONFIG_PACKAGE_luci-mod-freifunk),)
        PKG_SELECTED_MODULES+=modules/freifunk
 endif
@@ -651,6 +722,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-samba),)
        PKG_SELECTED_MODULES+=applications/luci-samba
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-uvc_streamer),)
+       PKG_SELECTED_MODULES+=applications/luci-uvc_streamer
+endif
 
 
 ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
@@ -669,6 +743,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-theme-openwrt),)
        PKG_SELECTED_MODULES+=themes/openwrt.org
 endif
+ifneq ($(CONFIG_PACKAGE_luci-theme-openwrtlight),)
+       PKG_SELECTED_MODULES+=themes/openwrt-light
+endif
 
 ifneq ($(CONFIG_PACKAGE_luci-i18n-german),)
        PKG_SELECTED_MODULES+=i18n/german
@@ -679,6 +756,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-i18n-french),)
        PKG_SELECTED_MODULES+=i18n/french
 endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-russian),)
+       PKG_SELECTED_MODULES+=i18n/russian
+endif
 
 
 MAKE_FLAGS += \
@@ -695,9 +775,11 @@ $(eval $(call BuildPackage,luci-cbi))
 $(eval $(call BuildPackage,luci-fastindex))
 $(eval $(call BuildPackage,luci-http))
 $(eval $(call BuildPackage,luci-ipkg))
+$(eval $(call BuildPackage,luci-json))
 $(eval $(call BuildPackage,luci-uci))
 $(eval $(call BuildPackage,luci-sys))
 $(eval $(call BuildPackage,luci-web))
+$(eval $(call BuildPackage,luci-uvl))
 
 $(eval $(call BuildPackage,luci-httpd))
 
@@ -710,6 +792,7 @@ $(eval $(call BuildPackage,luci-ff-augsburg))
 $(eval $(call BuildPackage,luci-admin-core))
 $(eval $(call BuildPackage,luci-admin-mini))
 $(eval $(call BuildPackage,luci-admin-full))
+$(eval $(call BuildPackage,luci-admin-rpc))
 $(eval $(call BuildPackage,luci-mod-freifunk))
 
 $(eval $(call BuildPackage,luci-app-ffwizard-leipzig))
@@ -722,6 +805,7 @@ $(eval $(call BuildPackage,luci-app-upnp))
 $(eval $(call BuildPackage,luci-app-ntpc))
 $(eval $(call BuildPackage,luci-app-ddns))
 $(eval $(call BuildPackage,luci-app-samba))
+$(eval $(call BuildPackage,luci-app-uvc_streamer))
 
 $(eval $(call BuildPackage,luci-sgi-cgi))
 $(eval $(call BuildPackage,luci-sgi-luci))
@@ -729,7 +813,9 @@ $(eval $(call BuildPackage,luci-sgi-webuci))
 
 $(eval $(call BuildPackage,luci-theme-fledermaus))
 $(eval $(call BuildPackage,luci-theme-openwrt))
+$(eval $(call BuildPackage,luci-theme-openwrtlight))
 
 $(eval $(call BuildPackage,luci-i18n-german))
 $(eval $(call BuildPackage,luci-i18n-english))
 $(eval $(call BuildPackage,luci-i18n-french))
+$(eval $(call BuildPackage,luci-i18n-russian))