* luci: fix an error in Makefile introduced by french translation
[project/luci.git] / contrib / package / luci / Makefile
index 5e74ea6..5ca9147 100644 (file)
@@ -36,7 +36,11 @@ include $(INCLUDE_DIR)/package.mk
 ifeq ($(USELOCAL),1)
   define Build/Prepare
        mkdir -p $(PKG_BUILD_DIR)
-       $(TAR) c -C ../../../ . --exclude=.pc --exclude='boa-0*' --exclude=.svn --exclude=.git | tar x -C $(PKG_BUILD_DIR)/
+       $(TAR) c -C ../../../ . \
+               --exclude=.pc --exclude=.svn --exclude=.git \
+               --exclude='boa-0*' --exclude='*.o' --exclude='*.so' \
+               --exclude=dist | \
+                       tar x -C $(PKG_BUILD_DIR)/
   endef
 endif
 
@@ -168,7 +172,7 @@ endef
 
 define Package/luci-web
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-http +luci-addons +luci-uci
+  DEPENDS+=+luci-http +luci-addons +luci-uci +luci-sgi-cgi
   TITLE:=MVC Webframework
 endef
 
@@ -330,7 +334,7 @@ endef
 
 define Package/luci-app-splash
   $(call Package/luci/fftemplate)
-  DEPENDS+=+iptables-mod-nat +iptables-mod-ipopt
+  DEPENDS+=+luasocket +iptables-mod-nat +iptables-mod-ipopt
   TITLE:=Freifunk DHCP-Splash application
 endef
 
@@ -362,7 +366,6 @@ endef
 
 define Package/luci-sgi-cgi
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-web
   TITLE:=SGI for CGI
 endef
 
@@ -372,7 +375,7 @@ endef
 
 define Package/luci-sgi-luci
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-web +luci-httpd
+  DEPENDS+=+luci-httpd
   TITLE:=SGI for LuCI HTTPD
 endef
 
@@ -382,7 +385,6 @@ endef
 
 define Package/luci-sgi-webuci
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-web
   TITLE:=SGI for Webuci
 endef
 
@@ -423,7 +425,7 @@ endef
 
 define Package/luci-i18n-english
   $(call Package/luci/i18ntemplate)
-  TITLE:=English (incomplete)
+  TITLE:=English
 endef
 
 define Package/luci-i18n-english/install
@@ -431,6 +433,17 @@ define Package/luci-i18n-english/install
 endef
 
 
+define Package/luci-i18n-french
+  $(call Package/luci/i18ntemplate)
+  TITLE:=French
+endef
+
+define Package/luci-i18n-french/install
+       $(call Package/luci/install/template,$(1),i18n/french)
+endef
+
+
+
 
 ### Compile ###
 ifneq ($(CONFIG_PACKAGE_luci-core),)
@@ -515,6 +528,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-i18n-english),)
        PKG_SELECTED_MODULES+=i18n/english
 endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-french),)
+       PKG_SELECTED_MODULES+=i18n/french
+endif
 
 
 MAKE_FLAGS += \
@@ -558,3 +574,4 @@ $(eval $(call BuildPackage,luci-theme-openwrt))
 
 $(eval $(call BuildPackage,luci-i18n-german))
 $(eval $(call BuildPackage,luci-i18n-english))
+$(eval $(call BuildPackage,luci-i18n-french))