contrib: make luci-lib-core depend on liblua-uci (#148, #150)
[project/luci.git] / contrib / package / luci / Makefile
index 9de1317..511722a 100644 (file)
@@ -29,14 +29,13 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 LUA_TARGET:=source
 LUCI_CFLAGS:=
 
 LUA_TARGET:=source
 LUCI_CFLAGS:=
-PKG_SELECTED_MODULES:=
+LUCI_BUILD_PACKAGES:=
+LUCI_SELECTED_MODULES:=
 
 ifeq ($(BOARD),brcm-2.4)
   MAKE_FLAGS += CRAP="1"
 endif
 
 
 ifeq ($(BOARD),brcm-2.4)
   MAKE_FLAGS += CRAP="1"
 endif
 
-BUILD_PACKAGES:=
-
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -55,7 +54,7 @@ define Build/Configure
 endef
 
 MAKE_FLAGS += \
 endef
 
 MAKE_FLAGS += \
-       MODULES="$(PKG_SELECTED_MODULES)" \
+       MODULES="$(LUCI_SELECTED_MODULES)" \
        LUA_TARGET="$(LUA_TARGET)" \
        LUA_SHLIBS="-llua -lm -ldl -lcrypt" \
        CFLAGS="$(TARGET_CFLAGS) $(LUCI_CFLAGS) -I$(STAGING_DIR)/usr/include" \
        LUA_TARGET="$(LUA_TARGET)" \
        LUA_SHLIBS="-llua -lm -ldl -lcrypt" \
        CFLAGS="$(TARGET_CFLAGS) $(LUCI_CFLAGS) -I$(STAGING_DIR)/usr/include" \
@@ -78,7 +77,7 @@ define Package/luci-lib-core
   URL:=http://luci.subsignal.org/
   MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
   SUBMENU:=Libraries
   URL:=http://luci.subsignal.org/
   MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
   SUBMENU:=Libraries
-  DEPENDS:=+lua
+  DEPENDS:=+lua +libuci-lua
   TITLE:=LuCI core libraries
 endef
 
   TITLE:=LuCI core libraries
 endef
 
@@ -121,10 +120,10 @@ ifneq ($(CONFIG_PACKAGE_luci-lib-core_zipped),)
 endif
 
 ifneq ($(CONFIG_PACKAGE_luci-lib-core),)
 endif
 
 ifneq ($(CONFIG_PACKAGE_luci-lib-core),)
-  PKG_SELECTED_MODULES+=libs/core
+  LUCI_SELECTED_MODULES+=libs/core
 endif
 
 endif
 
-BUILD_PACKAGES += luci-lib-core
+LUCI_BUILD_PACKAGES += luci-lib-core
 
 
 ### Libraries ###
 
 
 ### Libraries ###
@@ -146,10 +145,10 @@ define library
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-lib-$(1)),)
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-lib-$(1)),)
-    PKG_SELECTED_MODULES+=libs/$(1)
+    LUCI_SELECTED_MODULES+=libs/$(1)
   endif
 
   endif
 
-  BUILD_PACKAGES += luci-lib-$(1)
+  LUCI_BUILD_PACKAGES += luci-lib-$(1)
 endef
 
 define Package/luci-lib-lucid/extra-install
 endef
 
 define Package/luci-lib-lucid/extra-install
@@ -236,10 +235,10 @@ define Package/luci-mod-freifunk-community/install
 endef
 
 ifneq ($(CONFIG_PACKAGE_luci-mod-freifunk-community),)
 endef
 
 ifneq ($(CONFIG_PACKAGE_luci-mod-freifunk-community),)
-       PKG_SELECTED_MODULES+=applications/freifunk-community
+       LUCI_SELECTED_MODULES+=applications/freifunk-community
 endif
 
 endif
 
-BUILD_PACKAGES += luci-mod-freifunk-community
+LUCI_BUILD_PACKAGES += luci-mod-freifunk-community
 
 
 ### Modules ###
 
 
 ### Modules ###
@@ -261,10 +260,10 @@ define module
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-mod-$(1)),)
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-mod-$(1)),)
-    PKG_SELECTED_MODULES+=modules/$(1)
+    LUCI_SELECTED_MODULES+=modules/$(1)
   endif
 
   endif
 
-  BUILD_PACKAGES += luci-mod-$(1)
+  LUCI_BUILD_PACKAGES += luci-mod-$(1)
 endef
 
 
 endef
 
 
@@ -302,10 +301,10 @@ define application
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-app-$(1)),)
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-app-$(1)),)
-    PKG_SELECTED_MODULES+=applications/luci-$(1)
+    LUCI_SELECTED_MODULES+=applications/luci-$(1)
   endif
 
   endif
 
-  BUILD_PACKAGES += luci-app-$(1)
+  LUCI_BUILD_PACKAGES += luci-app-$(1)
 endef
 
 define Package/luci-app-splash/conffiles
 endef
 
 define Package/luci-app-splash/conffiles
@@ -440,10 +439,10 @@ define sgi
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-sgi-$(1)),)
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-sgi-$(1)),)
-    PKG_SELECTED_MODULES+=libs/sgi-$(1)
+    LUCI_SELECTED_MODULES+=libs/sgi-$(1)
   endif
 
   endif
 
-  BUILD_PACKAGES += luci-sgi-$(1)
+  LUCI_BUILD_PACKAGES += luci-sgi-$(1)
 endef
 
 $(eval $(call sgi,cgi,CGI Gateway behind existing Webserver))
 endef
 
 $(eval $(call sgi,cgi,CGI Gateway behind existing Webserver))
@@ -469,15 +468,15 @@ define theme
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-theme-$(1)),)
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-theme-$(1)),)
-    PKG_SELECTED_MODULES+=themes/$(1)
+    LUCI_SELECTED_MODULES+=themes/$(1)
   endif
 
   endif
 
-  BUILD_PACKAGES += luci-theme-$(1)
+  LUCI_BUILD_PACKAGES += luci-theme-$(1)
 endef
 
 $(eval $(call theme,base,Common base for all themes,,+luci-lib-web))
 $(eval $(call theme,openwrt,OpenWrt.org (default),,,1))
 endef
 
 $(eval $(call theme,base,Common base for all themes,,+luci-lib-web))
 $(eval $(call theme,openwrt,OpenWrt.org (default),,,1))
-$(eval $(call theme,openwrtlight,OpenWrt.org - light variant without images))
+$(eval $(call theme,openwrt-light,OpenWrt.org - light variant without images))
 $(eval $(call theme,fledermaus,Fledermaus Theme))
 
 $(eval $(call theme,freifunk,alternative Freifunk Theme,\
 $(eval $(call theme,fledermaus,Fledermaus Theme))
 
 $(eval $(call theme,freifunk,alternative Freifunk Theme,\
@@ -507,10 +506,10 @@ define translation
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-i18n-$(1)),)
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-i18n-$(1)),)
-    PKG_SELECTED_MODULES+=i18n/$(1)
+    LUCI_SELECTED_MODULES+=i18n/$(1)
   endif
 
   endif
 
-  BUILD_PACKAGES += luci-i18n-$(1)
+  LUCI_BUILD_PACKAGES += luci-i18n-$(1)
 endef
 
 $(eval $(call translation,german,German))
 endef
 
 $(eval $(call translation,german,German))
@@ -546,7 +545,7 @@ define collection
        true
   endef
 
        true
   endef
 
-  BUILD_PACKAGES += luci$(if $(1),-$(1))
+  LUCI_BUILD_PACKAGES += luci$(if $(1),-$(1))
 endef
 
 $(eval $(call collection,,\
 endef
 
 $(eval $(call collection,,\
@@ -561,13 +560,13 @@ $(eval $(call collection,ssl,\
 
 $(eval $(call collection,medium,\
        Medium package set using only admin full and a theme without graphics,\
 
 $(eval $(call collection,medium,\
        Medium package set using only admin full and a theme without graphics,\
-       +uhttpd +luci-mod-admin-full +luci-theme-openwrtlight))
+       +uhttpd +luci-mod-admin-full +luci-theme-openwrt-light))
 
 $(eval $(call collection,light,\
        Minimum package set using only admin mini and a theme without graphics,\
 
 $(eval $(call collection,light,\
        Minimum package set using only admin mini and a theme without graphics,\
-       +uhttpd +luci-mod-admin-mini +luci-theme-openwrtlight))
+       +uhttpd +luci-mod-admin-mini +luci-theme-openwrt-light))
 
 
 ### Compile ###
 
 
 ### Compile ###
-PKG_CONFIG_DEPENDS := $(patsubst %,CONFIG_PACKAGE_%,$(BUILD_PACKAGES))
-$(foreach b,$(BUILD_PACKAGES),$(eval $(call BuildPackage,$(b))))
+PKG_CONFIG_DEPENDS := $(patsubst %,CONFIG_PACKAGE_%,$(LUCI_BUILD_PACKAGES))
+$(foreach b,$(LUCI_BUILD_PACKAGES),$(eval $(call BuildPackage,$(b))))