Kill luci-addons package
[project/luci.git] / contrib / package / luci / Makefile
index b20c2c6..1e87596 100644 (file)
@@ -209,7 +209,7 @@ endef
 
 define Package/luci-web
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-http +luci-sys +luci-addons +luci-uci +luci-sgi-cgi
+  DEPENDS+=+luci-http +luci-sys +luci-uci +luci-sgi-cgi
   TITLE:=MVC Webframework
 endef
 
@@ -458,6 +458,16 @@ define Package/luci-app-uvc_streamer/install
 endef
 
 
+define Package/luci-app-p910nd
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full +p910nd
+  TITLE:=p910nd - Printer server module
+endef
+
+define Package/luci-app-p910nd/install
+        $(call Package/luci/install/template,$(1),applications/luci-p910nd)
+endef
+
 
 ### Server Gateway Interfaces ###
 
@@ -614,7 +624,7 @@ ifneq ($(CONFIG_PACKAGE_luci-mod-freifunk),)
 endif
 
 ifneq ($(CONFIG_PACKAGE_luci-freifunk-community),)
-       PKG_SELECTED_MODULES+=applications/luci-freifunk-community
+       PKG_SELECTED_MODULES+=applications/freifunk-community
 endif
 
 ifneq ($(CONFIG_PACKAGE_luci-app-ffwizard-leipzig),)
@@ -650,6 +660,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-uvc_streamer),)
        PKG_SELECTED_MODULES+=applications/luci-uvc_streamer
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-p910nd),)
+        PKG_SELECTED_MODULES+=applications/luci-p910nd
+endif
 
 
 ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
@@ -727,6 +740,7 @@ $(eval $(call BuildPackage,luci-app-ntpc))
 $(eval $(call BuildPackage,luci-app-ddns))
 $(eval $(call BuildPackage,luci-app-samba))
 $(eval $(call BuildPackage,luci-app-uvc_streamer))
+$(eval $(call BuildPackage,luci-app-p910nd))
 
 $(eval $(call BuildPackage,luci-sgi-cgi))
 $(eval $(call BuildPackage,luci-sgi-luci))