New application luci-upnp for luci-full and luci-mini
[project/luci.git] / contrib / package / luci / Makefile
index 6c92504..062e14c 100644 (file)
@@ -36,7 +36,11 @@ include $(INCLUDE_DIR)/package.mk
 ifeq ($(USELOCAL),1)
   define Build/Prepare
        mkdir -p $(PKG_BUILD_DIR)
-       $(TAR) c -C ../../../ . --exclude=.pc --exclude='boa-0*' --exclude=.svn --exclude=.git --exclude='*.o' | tar x -C $(PKG_BUILD_DIR)/
+       $(TAR) c -C ../../../ . \
+               --exclude=.pc --exclude=.svn --exclude=.git \
+               --exclude='boa-0*' --exclude='*.o' --exclude='*.so' \
+               --exclude=dist | \
+                       tar x -C $(PKG_BUILD_DIR)/
   endef
 endif
 
@@ -57,7 +61,7 @@ endef
 
 define Package/luci/fftemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI - Freifunk Support
+  SUBMENU:=LuCI - Freifunk Support (GERMAN ONLY)
   DEPENDS:=+luci-mod-freifunk
 endef
 
@@ -168,7 +172,7 @@ endef
 
 define Package/luci-web
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-http +luci-addons +luci-uci
+  DEPENDS+=+luci-http +luci-addons +luci-uci +luci-sgi-cgi
   TITLE:=MVC Webframework
 endef
 
@@ -249,12 +253,40 @@ define Package/luci-ff-hannover/install
 endef
 
 
+define Package/luci-ff-berlin
+  $(call Package/luci/fftemplate)
+  DEPENDS+= \
+   +luci-sgi-cgi +luci-app-splash +luci-app-olsr \
+   +luci-theme-fledermaus \
+   +luci-i18n-german \
+   +olsrd +olsrd-mod-dyn-gw +olsrd-mod-txtinfo +olsrd-mod-nameservice
+  TITLE:=Freifunk Berlin Community Meta-Package
+endef
+
+define Package/luci-ff-berlin/install
+       $(call Package/luci/install/template,$(1),applications/community-berlin)
+endef
+
+define Package/luci-ff-augsburg
+  $(call Package/luci/fftemplate)
+  DEPENDS+= \
+   +luci-sgi-cgi +luci-app-splash +luci-app-olsr \
+   +luci-theme-fledermaus \
+   +luci-i18n-german \
+   +olsrd +olsrd-mod-dyn-gw +olsrd-mod-txtinfo +olsrd-mod-nameservice
+  TITLE:=Freifunk Augsburg Community Meta-Package
+endef
+
+define Package/luci-ff-augsburg/install
+        $(call Package/luci/install/template,$(1),applications/community-augsburg)
+endef
+
 ### Modules ###
 
 define Package/luci-mod-admin-core
   $(call Package/luci/webtemplate)
   DEPENDS+=+luci-web +luci-cbi +luci-theme-openwrt +luci-i18n-english
-  TITLE:=Administration module
+  TITLE:=Administration core module
 endef
 
 define Package/luci-mod-admin-core/install
@@ -262,9 +294,31 @@ define Package/luci-mod-admin-core/install
 endef
 
 
+define Package/luci-mod-admin-mini
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-mod-admin-core
+  TITLE:=Simplified Administration module (INCOMPLETE)
+endef
+
+define Package/luci-mod-admin-mini/install
+       $(call Package/luci/install/template,$(1),modules/admin-mini)
+endef
+
+
+define Package/luci-mod-admin-full
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-mod-admin-core
+  TITLE:=Full featured Administration module
+endef
+
+define Package/luci-mod-admin-full/install
+       $(call Package/luci/install/template,$(1),modules/admin-full)
+endef
+
+
 define Package/luci-mod-freifunk
   $(call Package/luci/fftemplate)
-  DEPENDS:=+luci-mod-admin-core
+  DEPENDS:=+luci-mod-admin-full
   TITLE:=LuCI Freifunk module
 endef
 
@@ -308,7 +362,7 @@ endef
 
 define Package/luci-app-olsr
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-mod-admin-core +olsrd-mod-txtinfo
+  DEPENDS+=+luci-mod-admin-full +olsrd-mod-txtinfo
   TITLE:=OLSR configuration and status module
 endef
 
@@ -330,7 +384,7 @@ endef
 
 define Package/luci-app-splash
   $(call Package/luci/fftemplate)
-  DEPENDS+=+iptables-mod-nat +iptables-mod-ipopt
+  DEPENDS+=+luasocket +iptables-mod-nat +iptables-mod-ipopt
   TITLE:=Freifunk DHCP-Splash application
 endef
 
@@ -345,7 +399,7 @@ endef
 
 define Package/luci-app-statistics
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-mod-admin-core +collectd +collectd-mod-rrdtool1 +rrdtool1
+  DEPENDS+=+luci-mod-admin-full +collectd +collectd-mod-rrdtool1 +rrdtool1
   TITLE:=LuCI Statistics Application
 endef
 
@@ -357,12 +411,21 @@ define Package/luci-app-statistics/install
        $(call Package/luci/install/template,$(1),applications/luci-statistics)
 endef
 
+define Package/luci-app-upnp
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-mod-admin-core +miniupnpd
+  TITLE:=Universal Plug & Play configuration module
+endef
+
+define Package/luci-app-upnp/install
+       $(call Package/luci/install/template,$(1),applications/luci-upnp)
+endef
+
 
 ### Server Gateway Interfaces ###
 
 define Package/luci-sgi-cgi
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-web
   TITLE:=SGI for CGI
 endef
 
@@ -372,7 +435,7 @@ endef
 
 define Package/luci-sgi-luci
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-web +luci-httpd
+  DEPENDS+=+luci-httpd
   TITLE:=SGI for LuCI HTTPD
 endef
 
@@ -382,7 +445,6 @@ endef
 
 define Package/luci-sgi-webuci
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-web
   TITLE:=SGI for Webuci
 endef
 
@@ -423,7 +485,7 @@ endef
 
 define Package/luci-i18n-english
   $(call Package/luci/i18ntemplate)
-  TITLE:=English (incomplete)
+  TITLE:=English
 endef
 
 define Package/luci-i18n-english/install
@@ -431,6 +493,17 @@ define Package/luci-i18n-english/install
 endef
 
 
+define Package/luci-i18n-french
+  $(call Package/luci/i18ntemplate)
+  TITLE:=French
+endef
+
+define Package/luci-i18n-french/install
+       $(call Package/luci/install/template,$(1),i18n/french)
+endef
+
+
+
 
 ### Compile ###
 ifneq ($(CONFIG_PACKAGE_luci-core),)
@@ -465,10 +538,22 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-ff-hannover),)
        PKG_SELECTED_MODULES+=applications/community-hannover
 endif
+ifneq ($(CONFIG_PACKAGE_luci-ff-berlin),)
+       PKG_SELECTED_MODULES+=applications/community-berlin
+endif
+ifneq ($(CONFIG_PACKAGE_luci-ff-augsburg),)
+        PKG_SELECTED_MODULES+=applications/community-augsburg
+endif
 
 ifneq ($(CONFIG_PACKAGE_luci-mod-admin-core),)
        PKG_SELECTED_MODULES+=modules/admin-core
 endif
+ifneq ($(CONFIG_PACKAGE_luci-mod-admin-mini),)
+       PKG_SELECTED_MODULES+=modules/admin-mini
+endif
+ifneq ($(CONFIG_PACKAGE_luci-mod-admin-full),)
+       PKG_SELECTED_MODULES+=modules/admin-full
+endif
 ifneq ($(CONFIG_PACKAGE_luci-mod-freifunk),)
        PKG_SELECTED_MODULES+=modules/freifunk
 endif
@@ -491,6 +576,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-statistics),)
        PKG_SELECTED_MODULES+=applications/luci-statistics
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-upnp),)
+       PKG_SELECTED_MODULES+=applications/luci-upnp
+endif
 
 ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
        PKG_SELECTED_MODULES+=libs/sgi-cgi
@@ -515,6 +603,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-i18n-english),)
        PKG_SELECTED_MODULES+=i18n/english
 endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-french),)
+       PKG_SELECTED_MODULES+=i18n/french
+endif
 
 
 MAKE_FLAGS += \
@@ -538,8 +629,12 @@ $(eval $(call BuildPackage,luci-httpd))
 $(eval $(call BuildPackage,luci-ff-halle))
 $(eval $(call BuildPackage,luci-ff-leipzig))
 $(eval $(call BuildPackage,luci-ff-hannover))
+$(eval $(call BuildPackage,luci-ff-berlin))
+$(eval $(call BuildPackage,luci-ff-augsburg))
 
 $(eval $(call BuildPackage,luci-mod-admin-core))
+$(eval $(call BuildPackage,luci-mod-admin-mini))
+$(eval $(call BuildPackage,luci-mod-admin-full))
 $(eval $(call BuildPackage,luci-mod-freifunk))
 
 $(eval $(call BuildPackage,luci-app-ffwizard-leipzig))
@@ -548,6 +643,7 @@ $(eval $(call BuildPackage,luci-app-olsr))
 $(eval $(call BuildPackage,luci-app-qos))
 $(eval $(call BuildPackage,luci-app-splash))
 $(eval $(call BuildPackage,luci-app-statistics))
+$(eval $(call BuildPackage,luci-app-upnp))
 
 $(eval $(call BuildPackage,luci-sgi-cgi))
 $(eval $(call BuildPackage,luci-sgi-luci))
@@ -558,3 +654,4 @@ $(eval $(call BuildPackage,luci-theme-openwrt))
 
 $(eval $(call BuildPackage,luci-i18n-german))
 $(eval $(call BuildPackage,luci-i18n-english))
+$(eval $(call BuildPackage,luci-i18n-french))