(no commit message)
[project/luci.git] / contrib / package / haserl-lua / Makefile
index b214633..6d656db 100644 (file)
@@ -3,8 +3,6 @@
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
-#
-# $Id: Makefile 1719 2008-03-24 16:07:38Z Cyrus $
 
 include $(TOPDIR)/rules.mk
 
@@ -12,9 +10,10 @@ PKG_NAME:=haserl-lua
 PKG_VERSION:=0.9.23
 PKG_RELEASE:=1
 
-PKG_SOURCE:=haserl-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/haserl
-PKG_MD5SUM:=31d1f505afe3ba1b351e18612aa57a70
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://dev.leipzig.freifunk.net/svn/ff-luci/trunk/contrib/package-source/ \
+       http://firmware.freifunk-halle.net/ffluci/package-source/
+PKG_MD5SUM:=f3a0f329904791c5662d93638f92bdfd
 
 
 include $(INCLUDE_DIR)/package.mk
@@ -24,7 +23,7 @@ define Package/haserl-lua
   CATEGORY:=Utilities
   TITLE:=A CGI wrapper to embed shell scripts in HTML documents
   URL:=http://haserl.sourceforge.net/
-  DEPENDS:=+liblua
+  DEPENDS:=+liblua-luci
 endef
 
 CONFIGURE_ARGS += \
@@ -34,6 +33,8 @@ define Package/haserl-lua/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(STRIP) $(PKG_BUILD_DIR)/src/haserl
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/haserl $(1)/usr/bin/
+       echo "Replaces: haserl" >> $(1)/CONTROL/control
+       echo "Conflicts: haserl" >> $(1)/CONTROL/control
 endef
 
 $(eval $(call BuildPackage,haserl-lua))