* luci/contrib/olsr: sync initscript and config format to current Kamikaze version
[project/luci.git] / Makefile
index a9e5e1e..c90f11f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -15,7 +15,7 @@ gccbuild:
        for i in $(MODULES); do make -C$$i compile; done        
 
 luabuild:
-       for i in $(MODULES); do make -C$$i lua$(LUA_TARGET); done
+       for i in $(MODULES); do make -C$$i luabuild; done
 
 clean:
        rm -rf docs
@@ -62,6 +62,10 @@ hostclean: clean
 apidocs: hostenv
        build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "build/makedocs.sh host/luci/ docs"
 
+uvldocs: hostenv
+       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) \
+       "build/uvldoc $(realpath host) $(UVL_SCHEMEDIR) uvldocs $(DOCS)"
+
 run:
        #       make run is deprecated                          #
        #       Please use:                                     #