Completed first part of UVLDoc
[project/luci.git] / Makefile
index 558ee35..c90f11f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -62,6 +62,10 @@ hostclean: clean
 apidocs: hostenv
        build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "build/makedocs.sh host/luci/ docs"
 
+uvldocs: hostenv
+       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) \
+       "build/uvldoc $(realpath host) $(UVL_SCHEMEDIR) uvldocs $(DOCS)"
+
 run:
        #       make run is deprecated                          #
        #       Please use:                                     #