Fixed UCI save support for LuCI SDK
[project/luci.git] / Makefile
index a9e5e1e..6c7d399 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -15,7 +15,7 @@ gccbuild:
        for i in $(MODULES); do make -C$$i compile; done        
 
 luabuild:
        for i in $(MODULES); do make -C$$i compile; done        
 
 luabuild:
-       for i in $(MODULES); do make -C$$i lua$(LUA_TARGET); done
+       for i in $(MODULES); do make -C$$i luabuild; done
 
 clean:
        rm -rf docs
 
 clean:
        rm -rf docs
@@ -29,11 +29,12 @@ gcchost: gccbuild hostcopy
 luahost: luabuild hostcopy
 
 hostcopy: 
 luahost: luabuild hostcopy
 
 hostcopy: 
-       mkdir -p host
+       mkdir -p host/tmp
        for i in $(MODULES); do cp -a $$i/dist/* host/ -R 2>/dev/null || true; done
        for i in $(MODULES); do cp -a $$i/hostfiles/* host/ -R 2>/dev/null || true; done
        rm -f host/luci
        ln -s .$(LUCI_MODULEDIR) host/luci
        for i in $(MODULES); do cp -a $$i/dist/* host/ -R 2>/dev/null || true; done
        for i in $(MODULES); do cp -a $$i/hostfiles/* host/ -R 2>/dev/null || true; done
        rm -f host/luci
        ln -s .$(LUCI_MODULEDIR) host/luci
+       rm -rf /tmp/luci-* || true
 
 hostenv: host ucidefaults
 
 
 hostenv: host ucidefaults
 
@@ -62,6 +63,10 @@ hostclean: clean
 apidocs: hostenv
        build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "build/makedocs.sh host/luci/ docs"
 
 apidocs: hostenv
        build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "build/makedocs.sh host/luci/ docs"
 
+uvldocs: hostenv
+       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) \
+       "build/uvldoc $(realpath host) $(UVL_SCHEMEDIR) uvldocs $(DOCS)"
+
 run:
        #       make run is deprecated                          #
        #       Please use:                                     #
 run:
        #       make run is deprecated                          #
        #       Please use:                                     #