[tools] yaffs2: link statically
[openwrt.git] / tools / yaffs2 / Makefile
index 344b61a..8615fd3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,12 +15,14 @@ PKG_SOURCE_URL:=git://android.git.kernel.org/platform/external/yaffs2.git
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)
 PKG_SOURCE_VERSION:=d333fc232d7e5ae3370080d5d6f7d88ea9c6b3a1
+PKG_MIRROR_MD5SUM:=8145d4dd9b46face26121f27ad60cc1c
 HOST_BUILD_DIR=$(BUILD_DIR_HOST)/$(PKG_NAME)
 
 include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR)/yaffs2/utils \
+               CC="$(HOSTCC) -static" \
                CFLAGS="$(HOST_CFLAGS) -include endian.h" \
                mkyaffs2image
 endef