[tools] use HOST_STATIC_LINKING instead of hardcoding -static
[openwrt.git] / tools / m4 / Makefile
index 91efb5b..6470a54 100644 (file)
@@ -16,7 +16,7 @@ PKG_CAT:=zcat
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_LDFLAGS += -static
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
 
 define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall