tools: Fix compilation on x32 host
[openwrt.git] / tools / gmp / Makefile
index 5028ae0..b1976d0 100644 (file)
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gmp
-PKG_VERSION:=5.1.1
+PKG_VERSION:=5.1.3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gmp/
-PKG_MD5SUM:=485b1296e6287fa381e6015b19767989
+PKG_MD5SUM:=e5fe367801ff067b923d1e6a126448aa
 
 HOST_FIXUP:=autoreconf
 
@@ -27,4 +27,8 @@ HOST_CONFIGURE_ARGS += \
        --enable-cxx \
        --enable-mpbsd
 
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += ABI=x32
+endif
+
 $(eval $(call HostBuild))