[tools] use HOST_STATIC_LINKING instead of hardcoding -static
[openwrt.git] / tools / genext2fs / Makefile
index 67fbef6..57e8d35 100644 (file)
@@ -35,7 +35,8 @@ HOST_CONFIGURE_ARGS = \
 
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR) \
-               CFLAGS="$(HOST_CFLAGS) -include getline.h" \
+               CFLAGS="$(HOST_CFLAGS)" \
+               LDFLAGS="$(HOST_LDFLAGS) $(HOST_STATIC_LINKING)" \
                all
 endef