[tools] use HOST_STATIC_LINKING instead of hardcoding -static
[openwrt.git] / tools / genext2fs / Makefile
index 2462b8c..57e8d35 100644 (file)
@@ -36,7 +36,7 @@ HOST_CONFIGURE_ARGS = \
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR) \
                CFLAGS="$(HOST_CFLAGS)" \
-               LDFLAGS="$(HOST_LDFLAGS) -static" \
+               LDFLAGS="$(HOST_LDFLAGS) $(HOST_STATIC_LINKING)" \
                all
 endef