firmware-utils: remove the wndr3700 utility
[openwrt.git] / tools / firmware-utils / Makefile
index cd7531f..b53faaa 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 define cc
-       $(HOSTCC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
+       $(HOSTCC) $(HOST_CFLAGS) -include endian.h $(HOST_STATIC_LINKING) -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
 endef
 
 define Host/Compile
@@ -21,6 +21,7 @@ define Host/Compile
        $(call cc,trx)
        $(call cc,motorola-bin)
        $(call cc,dgfirmware)
+       $(call cc,mkdir615h1 md5)
        $(call cc,trx2usr)
        $(call cc,ptgen)
        $(call cc,airlink)
@@ -39,10 +40,10 @@ define Host/Compile
        $(call cc,nand_ecc)
        $(call cc,mkplanexfw sha1)
        $(call cc,mktplinkfw md5)
+       $(call cc,mktplinkfw2 md5)
        $(call cc,pc1crypt)
        $(call cc,osbridge-crc)
        $(call cc,wrt400n cyg_crc32)
-       $(call cc,wndr3700)
        $(call cc,mkdniimg)
        $(call cc,mktitanimg)
        $(call cc,mkchkimg)
@@ -55,6 +56,15 @@ define Host/Compile
        $(call cc,buffalo-tftp buffalo-lib, -Wall)
        $(call cc,mkwrgimg md5, -Wall)
        $(call cc,mkedimaximg)
+       $(call cc,mkbrncmdline)
+       $(call cc,mkbrnimg)
+       $(call cc,mkdapimg)
+       $(call cc, mkcameofw, -Wall)
+       $(call cc,seama md5)
+       $(call cc,fix-u-media-header cyg_crc32,-Wall)
+       $(call cc,hcsmakeimage bcmalgo)
+       $(call cc,mkporayfw, -Wall)
+       $(call cc,mkdcs932, -Wall)
 endef
 
 define Host/Install