[brcm63xx] rework imagetag firmware generator and MTD partition parser to accomodate...
[openwrt.git] / tools / firmware-utils / Makefile
index b162236..4e5789b 100644 (file)
@@ -10,6 +10,8 @@ PKG_NAME := firmware-utils
 
 include $(INCLUDE_DIR)/host-build.mk
 
+include $(INCLUDE_DIR)/kernel.mk
+
 define cc
        $(CC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/bin/$(1) src/$(1).c $(2)
 endef
@@ -18,6 +20,11 @@ define cc2
        $(CC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
 endef
 
+define cc3
+       $(CC) $(HOST_CFLAGS) -I$(CURDIR)/../../target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx -include endian.h -o $(HOST_BUILD_DIR)/bin/$(1) src/$(1).c $(2)
+endef
+
+
 define Host/Compile
        mkdir -p $(HOST_BUILD_DIR)/bin
        $(call cc,addpattern)
@@ -35,7 +42,7 @@ define Host/Compile
        $(call cc,mkcasfw)
        $(call cc,mkfwimage,-lz)
        $(call cc,mkfwimage2,-lz)
-       $(call cc,imagetag)
+       $(call cc3,imagetag)
        $(call cc,add_header)
        $(call cc,makeamitbin)
        $(call cc,encode_crc)