[tools] reenable squashfs4 for ar71xx, it needs both old and new
[openwrt.git] / tools / Makefile
index 3fbac93..91e980e 100644 (file)
@@ -19,12 +19,10 @@ tools-y += sstrip ipkg-utils genext2fs libuuid mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2
 tools-$(CONFIG_TARGET_orion) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
-ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25),)
-tools-y += squashfs lzma-old
-else
-ifneq ($(CONFIG_TARGET_ar71xx),)
+ifneq ($(CONFIG_LINUX_2_6_25)$(CONFIG_TARGET_ar71xx),)
 tools-y += squashfs lzma-old
 endif
+ifeq ($(CONFIG_LINUX_2_6_25),)
 tools-y += squashfs4 lzma
 endif
 tools-$(CONFIG_CCACHE) += ccache
@@ -48,11 +46,13 @@ $(curdir)/mpc/compile := $(curdir)/gmp/install
 $(curdir)/mpfr/compile := $(curdir)/gmp/install
 $(curdir)/mtd-utils/compile := $(curdir)/libuuid/install
 $(curdir)/mkimage/compile := $(curdir)/sed/install
+$(curdir)/qemu/compile := $(curdir)/libuuid/install
 $(curdir)/upslug2/compile := $(curdir)/automake/install
 
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)
 
+ifndef DUMP_TARGET_DB
 define PrepareStaging
        @for dir in $(1); do ( \
                set -x; \
@@ -83,6 +83,7 @@ $(STAGING_DIR_HOST)/bin/$(1): $(STAGING_DIR)/.prepared
        }; ln -s "$$$$FILE" "$$@"
 
 endef
+endif
 
 $(eval $(call PrepareCommand,find,gfind find))
 $(eval $(call PrepareCommand,md5sum,md5sum $(SCRIPT_DIR)/md5sum))