rename tools/lzma to tools/lzma-old (preparation for adding a new lzma version)
[openwrt.git] / tools / Makefile
index 49c450f..19ee453 100644 (file)
@@ -9,18 +9,22 @@
 curdir:=tools
 
 # subdirectories to descend into
-tools-y := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config m4 autoconf automake bison quilt yaffs2
+tools-y :=
+tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
+tools-y += m4 autoconf automake bison pkg-config sed
+tools-y += sstrip ipkg-utils genext2fs squashfs mtd-utils lzma-old mkimage
+tools-y += firmware-utils patch-cmdline quilt yaffs2
 
 tools-$(CONFIG_CCACHE) += ccache
 tools-$(CONFIG_powerpc) += dtc
-tools-$(CONFIG_GCC_VERSION_4_3) += gmp mpfr
 
 # builddir dependencies
-$(curdir)/squashfs/compile := $(curdir)/lzma/install
+$(curdir)/squashfs/compile := $(curdir)/lzma-old/install
 $(curdir)/quilt/compile := $(curdir)/sed/install
 $(curdir)/dtc/compile := $(curdir)/bison/install
 $(curdir)/autoconf/compile := $(curdir)/m4/install
-$(curdir)/automake/compile := $(curdir)/m4/install
+$(curdir)/automake/compile := $(curdir)/m4/install $(curdir)/autoconf/install
+$(curdir)/mpfr/compile := $(curdir)/gmp/install
 
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)
@@ -59,5 +63,5 @@ $(curdir)//compile = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
 $(curdir)/ := .config prereq
 $(curdir)//install = $(1)/compile
 
-$(eval $(call stampfile,$(curdir),tools,install))
+$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_3))
 $(eval $(call subdir,$(curdir)))