Don't build gmp and mpfr when using external toolchains (based on patch from #6035)
[openwrt.git] / tools / Makefile
index 71c0346..1456c0d 100644 (file)
@@ -10,8 +10,10 @@ curdir:=tools
 
 # subdirectories to descend into
 tools-y :=
+ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
 tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
-tools-y += m4 autoconf automake bison pkg-config sed
+endif
+tools-y += m4 autoconf automake bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs squashfs squashfs4 mtd-utils lzma-old mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2
 
@@ -19,6 +21,11 @@ tools-$(CONFIG_CCACHE) += ccache
 tools-$(CONFIG_powerpc) += dtc
 tools-dep += lzma
 
+ifdef CONFIG_GCC_VERSION_4_4
+  tools-y += ppl cloog
+  $(curdir)/cloog/compile := $(curdir)/ppl/install
+endif
+
 # builddir dependencies
 $(curdir)/pkg-config/compile := $(curdir)/sed/install
 $(curdir)/squashfs/compile := $(curdir)/lzma-old/install